Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Well this is embarrassing........." message EVERY SINGLE time I open Firefox

  • 34 svar
  • 169 har dette problem
  • 33293 visninger
  • Seneste svar af wpk9327

more options

I am now getting the 'well this is embarrassing...' message EVERY time I open Firefox; I have my Home page set to always open 9 tabs - these are the SAME tabs I have opened at start-up for about 2 years - WHY this annoying message now?! When I click 'close' the Home page opens with all the tabs with no problem, but the message is really irritating & doesn't seem to be telling me anything, as there isn't a problem with any of the tabs? NB: In case you ask 'why 9 tabs'?; these are essential websites I use every time I am browsing/working; I cannot keep opening them manually every time. Please advise why this message comes up as here seems to be no problem, & how I can get rid of it? Thanks.

Valgt løsning

A likely cause is that you are first closing all Firefox windows and then close the Firefox application.

Some have reported that closing Firefox (Firefox > Quit) while the browser window is still open works for them.


  • Bug 845681 - Closing all windows and quitting Firefox afterwards leads to about:sessionrestore to be shown on next startup

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Læs dette svar i sammenhæng 👍 7

Alle svar (14)

more options

Well, the bug has returned. Firefox is once again embarrassed for no good reason. We look forward to Firefox version 20.x

more options

I'm still closing FF without closing the last window I was working in and so far every time I sign on, Yahoo! is there waiting for me!!

more options

I found that if you set browser.sessionstore.resume_from_crash to false, the problem disappears. The only thing is, Firefox will no longer resume from a crash. I have to be sure to bookmark every page I want to keep.

more options

Does this also happen if you do not reopen pages automatically the next time?

I.e. you use one of these: "Show my home page" or "Show a blank page"

more options

I have my browser set to open my home page, which is about:blank.

more options

This has been a problem created in version 19 and now 20 which has not been addressed. I do not want to play around with settings, I want it to work in the first place please. I couldn't even get a password reminder even though I did it 6 times and had to re-register with exactly the same username/email address and it did not say that this name was already taken and just gave me what I already had which is pretty lame. The browser should just work. Other browsers do not do this only Firefox. There is always so much justification and hoop-jumping instead of the bug getting fixed. It's a simple software issue which Mozilla needs to sort out instead of recreating on every version. I use a computer to do things and not to find countless excuses. I appreciate the Mozilla is a voluntary platform to a large extent but creating things that do not work is a daft thing to do. Test your meta models properly before releasing instead of constantly building the same problems into each version please.

Ændret af hughmoz den

more options

Has this still not been fixed yet?? I only ask because I stopped using Firefox when this "embarrassing" bug first appeared, using safari now without the "embarrassing" bug lol

more options

Hi there

Well it hasn't on my Mac, however, this is typical Mozilla. If one person flags a problem and it exists then why not fix it instead of ignoring it until thousands have flagged the same issue and continue to do nothing about it?

Ændret af hughmoz den

more options

With the latest update to Firefox (version 21.0), this issue appears to have been fixed. Thanks guys :-)

more options

Hi there

Thanks for that. I just downloaded it and my Apps file on my Mac said I was replacing a newer edition with an older one although, I was running 20.0 ?!?!?! but I did it and then used the browser for a while, turned off my Mac, powered it up again and it appears to work. Mozilla have had numerous new versions of Firefox in recent years. It's just a browser and I fail to see why they make such a hash of it at regular intervals and feel the need to keep mucking it about. My other browsers function perfectly and are not updated everytime someone has a daft idea.

more options

Unfortunately I believe not, but I found a solution that seems to be working for me. Cookies are things that keep email accounts and things signed in, they also put up adds from the website you were previously at. So I just deselected remember my browsing and download history and left on accept third party cookies. This left my Gmail logged in but my history deleted every time. Hope this helped, sorry if I sound like a retard. :D

more options

Hi there, That may be helpful for some, however, since downloading version 21.0 I have not had any problem when booting up and then using Firefiox which opens at its normal homepage with Google which is what I use on this browser on my Mac. So, I am well pleased that it appears that Mozilla have fixed this, and thank them for getting it together at long last. If it goes pear shaped again I will just use another browser that works. Mozilla have a poor track record with Firefox and Thunderbird of ruining platforms that work just to tweak silly stuff and add all sorts of techy dross. Most people probably just want something that works that is simple to use rather than expecting a tardis situation. Keep it simple and stop playing around with it every few minutes is my call. :)

more options

I agree with Hughmoz. Firefox is getting heavier and heavier. I've found that it often causes the BBC iPlayer to stall, what's telling is that if I go to Help, select "Restart with add ons disabled" and then start iPlayer, the stalling will often completely disappear. I haven't got many add ons but they evidently impact performance.

more options

I was having the problem on my MacBook Pro for a while. I was also having a problem with Netflix. Very often, when I tried playing a show or movie, I'd get only a white or black page, with nothing happening. Looking for a solution, I found the page http://machow2.com/netflix-for-mac/, which contains a section titled How to fix Netflix for Mac Silverlight problems in Firefox, and I followed the instructions in that section to completely remove and reinstall the Silverlight plugin. It solved the Netflix problem, and it also seems to have eliminated the "Well, this is embarrassing" problem.

  1. 1
  2. 2