Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adjusting a URL and reloading causes it to go to Google - any way to just let it reload the page?

  • 7 svar
  • 1 har dette problem
  • 373 visninger
  • Seneste svar af jscher2000

more options

I was testing some calls to a Solr index with different URL query parameters. But each time I adjust a parameter and reload the page, instead of making the call again I'm dropped into Google search.

However, if I (tediously) manually edit the URL to specifically add back in "http://" at the beginning of the line I can reload the page.

This doesn't happen in Safari or Chrome. It seems to be a problem unique to FireFox.

It makes testing cumbersome and I was wondering if there was a solution for this.

Thanks,

doug

Valgt løsning

I forgot to mention that you can default the http:// at the beginning of the URL. I did this so long ago it just occurred to me.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste trim and pause while the list is filtered

(3) Double-click browser.urlbar.trimURLs to switch its value from true to false. You're done here.

Læs dette svar i sammenhæng 👍 0

Alle svar (7)

more options

Could you describe how you are making the calls? For example, are you setting window.location.href, using window.open(), etc.? Submitting a form?

One reason for getting a search could be a space in the URL. Is there any way to avoid spaces in the URL, or can you confirm that they are being properly encoded to %20?

Do you want to try disabling address bar search (keyword search) as a workaround? https://support.mozilla.org/en-US/kb/search-web-address-bar#w_turning-off-the-internet-keyword-search

more options

I am making the call by entering the URL in the address bar.

The URL is url-encoded, so all spaces are encoded to %20.

If I disable address bar search does that mean there would be a separate address bar and search field, like in "oldey times"?

I think this happens when there is no explicit "www" hostname at the beginning of the URL.

Thanks,

doug

more options

Valgt løsning

I forgot to mention that you can default the http:// at the beginning of the URL. I did this so long ago it just occurred to me.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste trim and pause while the list is filtered

(3) Double-click browser.urlbar.trimURLs to switch its value from true to false. You're done here.

more options

If I disable address bar search does that mean there would be a separate address bar and search field, like in "oldey times"?

It means that if the URL doesn't resolve to a real page, you get a page not found error instead of going to a search results page. (Sometimes an ISP will substitute its own page, so you're not guaranteed to get a 404 error page...). You could indeed search from the search bar/search box.

more options

Toggling keyword.enabled to false did not help.

Interestingly enough I can reload the page without a problem, if I don't modify the URL.

doug

more options

The browser.urlbar.trimURLs solution worked perfectly. Thanks!

OK. Sticking with FireFox as my main browser. :)

I have a list of "annoyances with browsers" and keep going back and forth, but have been using FireFox for the last 6 months or so as my "main browser" and Safari and Chrome as "testing or secondary browsers."

My short list was:

  1. Safari - Can no longer see status of a background tab loading, so I always have to go back to the tab to see if it is done. Frequently has slowdown issues.
  2. FireFox - Weirdness with URLs - can't modify a URL and have it load again unless you explicitly type in http://. (But you just solved that problem for me!)
  3. Chrome - Video streaming choppy - even from YouTube! Bookmark menu folder items look very tiny and cheap compared to FireFox and Chrome, no way to increase font size. Sometimes issues with going to my Gmail page (too many redirects).

Anyway, thanks!

doug

Ændret af douglerner den

more options

Thanks for testing and posting confirmation. Hiding the http:// wasn't intended to change functionality, so perhaps that's a bug.