X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Need to PREVENT automatic re-painting of non-focus pages as content on them changes.

Skrevet

I use multiple tabs in 1 or 2 windows, and SOME of the pages have continuously updated information in some areas. Apparently Firefox is set to SWITCH FOCUS from whatever I am looking at to whichever page/tab has a fresh update. This causes no end of grief, as I may be in the middle of reading a sentence, or scrolling to find a particular item in a page, or responding in a text field, and all of a sudden my display bounces to an page that is unrelated to what I am doing. Unacceptable. I note, in addition, that this is a problem EVEN IF I ONLY HAVE ONE PAGE/TAB/WINDOW open, in that it can bounce me from where I am looking to where I haven't asked to look, and this can happen EVEN WHEN I AM HOLDING DOWN THE LMB WHILE CONTROLLING SCROLLING TO FIND SOMETHING ON THE CURRENT PAGE.

None of these behaviors make sense, and all interrupt browsing, rendering it annoying to completely ineffective. The correct way to handle continuous updating of browser information is to ONLY shift to a new location when the user is NOT actively controlling the current activity on the current display, either by using navigation commands such as scrolling, or by active input to the screen.

Does Firefox currently have a way for me to STOP the automatic re-display of updating pages?

I am using v12.0. (I note that I do NOT recall this being a huge problem until I upgraded from a much-earlier version.)

I use multiple tabs in 1 or 2 windows, and SOME of the pages have continuously updated information in some areas. Apparently Firefox is set to SWITCH FOCUS from whatever I am looking at to whichever page/tab has a fresh update. This causes no end of grief, as I may be in the middle of reading a sentence, or scrolling to find a particular item in a page, or responding in a text field, and all of a sudden my display bounces to an page that is unrelated to what I am doing. Unacceptable. I note, in addition, that this is a problem EVEN IF I ONLY HAVE ONE PAGE/TAB/WINDOW open, in that it can bounce me from where I am looking to where I haven't asked to look, and this can happen EVEN WHEN I AM HOLDING DOWN THE LMB WHILE CONTROLLING SCROLLING TO FIND SOMETHING ON THE CURRENT PAGE. None of these behaviors make sense, and all interrupt browsing, rendering it annoying to completely ineffective. The correct way to handle continuous updating of browser information is to ONLY shift to a new location when the user is NOT actively controlling the current activity on the current display, either by using navigation commands such as scrolling, or by active input to the screen. Does Firefox currently have a way for me to STOP the automatic re-display of updating pages? I am using v12.0. (I note that I do NOT recall this being a huge problem until I upgraded from a much-earlier version.)

Yderligere systemdetaljer

Installerede plugins

  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Program

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

Yderligere information

Luk
Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 løsninger 10738 svar

first, you need to update to Firefox 17.0.1, as Firefox 12 is not only horribly insecure, but there are several known bugs that are fixed in 17. Update Firefox to the latest release

After doing that, please retest your problem. If it still happens, please give me some more details (sites I can test, etc.)

first, you need to update to Firefox 17.0.1, as Firefox 12 is not only horribly insecure, but there are several known bugs that are fixed in 17. [[Update Firefox to the latest version]] After doing that, please retest your problem. If it still happens, please give me some more details (sites I can test, etc.)

Spørgsmålsstiller

Thanks for responding so quickly. I can do the upgrade, but if you're not already aware of a way to configure this, it will probably make no difference. A simple way to see it is to go to Marketwatch.com, set up a stock portfolio of 20 active stocks and set a page to display the portfolio. Then open another tab and display some text from anywhere that requires scrolling past the end of the screen. Hold the mouse button down and scroll in the text. When the stock portfolio is updated, the display focus shifts back to the portfolio page EVEN IF YOU ARE ACTIVELY SCROLLING IN TEXT. Similarly, you can open a page with a text fill-in box and be typing in the box, and a stock update will shift focus AWAY FROM THE PAGE WHERE YOU ARE TYPING. (Happened to me while filling out this box.)

Thanks for responding so quickly. I can do the upgrade, but if you're not already aware of a way to configure this, it will probably make no difference. A simple way to see it is to go to Marketwatch.com, set up a stock portfolio of 20 active stocks and set a page to display the portfolio. Then open another tab and display some text from anywhere that requires scrolling past the end of the screen. Hold the mouse button down and scroll in the text. When the stock portfolio is updated, the display focus shifts back to the portfolio page EVEN IF YOU ARE ACTIVELY SCROLLING IN TEXT. Similarly, you can open a page with a text fill-in box and be typing in the box, and a stock update will shift focus AWAY FROM THE PAGE WHERE YOU ARE TYPING. (Happened to me while filling out this box.)
Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 løsninger 10738 svar

Do the update anyway, as it contains other important fixes. While you do that, I'll look at this site. I think there is an addon that prevents sites form auto-refreshing

Do the update anyway, as it contains other important fixes. While you do that, I'll look at this site. I think there is an addon that prevents sites form auto-refreshing