Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

What happened to the firefox icon on htm and html document files?

  • 26 svar
  • 6 har dette problem
  • 10946 visninger
  • Seneste svar af Claudia

more options

Today I have noticed it for the first time.. The icon use to look like a blank page with a mini firefox icon on it.. Now the htm and html icon looks like a blank white page that is bent on the top right hand corner.. I tried a firefox reset and it didn't help.. I don't wanna do a reinstall of firefox because I want to keep the old firefox download manager and not the new one that is on the right of the search bar.. ( I saw it on my ubuntu linux computer) BUT my computer with the html file icon problem is Windows 7 x64

Valgt løsning

It does say it is a Firefox HTML Document but it doesn't show the firefox icon on the html file icon.. I'm going to just uninstall and reinstall.. Hopefully it will help

Læs dette svar i sammenhæng 👍 0

All Replies (20)

more options

If you right-click one of those desktop icons, then

Properties > Web Document tab > "Change Icons" button

Does the dialog show that it is using icons from the firefox.exe file:

C:\Program Files (x86)\Mozilla Firefox\firefox.exe

If it shows some other program or file, then you could change it back in this dialog, or perhaps Firefox is no longer your default browser??

more options

By the way, what do you mean about the new download manager?? That might be a change to an add-on rather than a built-in feature. If it's a problem, you could post a new thread about it or maybe add a screen shot in a reply here.

more options

Try to rebuild the Windows icon cache.

  1. Open the Task Manager (Shift+Ctrl+ESC)
  2. In the Process tab, right-click on the Explorer.exe process and select End Process.
  3. Open the file picker via "File > New Task (Run)" and click the Browse button.
  4. Type or Paste %USERPROFILE%\AppData\Local in the File name field (AppData is a hidden folder).
  5. Select the IconCache.db file and use "Delete" in the right-click context menu to delete the file.
  6. After the IconCache.db file has been deleted, start a new explorer.exe process via "File > New Task" to get the desktop and Taskbar back.

Verify in Windows Explorer that you can see the IconCache.db file before doing the above mentioned steps because the IconCache.db file may be a hidden file.

See http://kb.mozillazine.org/Show_hidden_files_and_folders

more options

Firefox is my default browser.

more options

But the icon still looks the same..

more options

You can disable the new download manager with the drop down list by setting the browser.download.useToolkitUI pref to true on the about:config page.

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

Here is a screenshot of a ".html" file icon that i am currently seeing.. I did the icon cache rebuild thing but that didn't help.. I use to see a little firefox icon on the icon..

more options

I would like to see in which place(s) that you see that icon.

Can you attach a screenshot that shows the context where you see that icon.

more options

I see that white icon on any .htm and .html document saved on my computer. On the .url files I see the icon that i use to see on htm and html files.. The image attached now is the icon of a .url file.

more options

Oops, I was looking at the right-click menu for a shortcut instead of a .html file.

Are you sure Firefox is the default program for opening .html files? You can check in the Windows Control Panel for setting file associations:

Control Panel > Programs > Default Programs > Set Associations

.htm and .html should say "Firefox HTML Document"


If that doesn't help...

Microsoft did not include the old "File Types" tab in Windows Vista/Windows 7, so there isn't a graphical interface for switching the default icon for a particular file type.

If you are comfortable editing the Windows registry, you could check the following setting. There also are third party programs that apparently allows you to change icons (I haven't tried any of them myself).

  • HKEY_CLASSES_ROOT\FirefoxHTML\DefaultIcon
    (Default) = C:\Program Files (x86)\Mozilla Firefox\firefox.exe,1

Ændret af jscher2000 den

more options

I checked the regedit.exe and it does say that FirefoxHTML Defaulticon is C:\Program Files (x86)\Mozilla Firefox\firefox.exe,1... I'm thinking of uninstalling firefox and reinstalling..

more options

You might first try switching your default browser to IE and then switching it back to Firefox to refresh the full set of registry settings; less risky than an uninstall/reinstall cycle.

more options

Switch default browser to IE9 then back to firefox and it didn't help

more options

If Windows Explorer identifies .html files as "Firefox HTML Document", and the registry points to the correct icon for that document type, and you've rebuilt the icon cache, then it's hard to see where the break is in the chain.

more options

Valgt løsning

It does say it is a Firefox HTML Document but it doesn't show the firefox icon on the html file icon.. I'm going to just uninstall and reinstall.. Hopefully it will help

more options

I'm back from reinstalling Firefox.. It solved the problem.. Thanks for the help.

more options

It didn't solve it for me. I have tried the switch icons, uninstall and reinstall, making IE default and then back to FF, file association (there is no Program group in Control Panel in XP btw, the earlier Contributor poster is thinking only of Win7) and scanned other forums without any solution. mhtml and html files save fine, but are tagged with the Windows default icon for a program the o/s does not recognise. This causes constant irritation because while quickly browsing data files, my eye falls on the unrecognised file icon and I pause wondering what is the problem before realising it's the Firefox error yet again. There are FF users on other forums with the same problem too, some devising solutions which work for them but not for others, probably because computers are so individual. I am a recent convert to Windows XP 64-bit sp2 on a new build. With my previous 32-bit machines, I had no problem. I think, like Apple, Firefox has not come to terms with 64-bit despite it supposedly being "the future." I use FF v12 because I can't stand the look of its successors. However, from browsing forums, I gather it makes no matter what version is used. It seemingly happened after v11 and continues throughout. Any help would be greatly appreciated. Thanks.

more options

Try to rebuild the Windows icon cache.

  1. Open the Task Manager (Shift+Ctrl+ESC)
  2. In the Process tab, right-click on the Explorer.exe process and select End Process.
  3. Open the file picker via "File > New Task (Run)" and click the Browse button.
  4. Type or Paste %USERPROFILE%\AppData\Local in the File name field (AppData is a hidden folder).
  5. Select the IconCache.db file and use "Delete" in the right-click context menu to delete the file.
  6. After the IconCache.db file has been deleted, start a new explorer.exe process via "File > New Task" to get the desktop and Taskbar back.
more options

Thanks cor-el, but it didn't work. For FF saved pages/items on my hard drive, I still have the default icon which is given by Windows to the file of an unrecognised program.

more options

hi in case it helps; my problem began when i moved FF location; it left behind [HKEY_CLASSES_ROOT\CLSID\{42042206-2D85-11D3-8CFF-005004838597}\Old Icon\FirefoxHTML\DefaultIcon] this key; the real icon location; now.. that long number may be different from 1 M$ install to another.. dig it up; another solution is to search old path association inside registry

  1. 1
  2. 2