X
Tryk her for at gå til webstedets mobilversion.

Supportforum

certificate problem, but option to accept anyway has gone.

Skrevet

since upgrading to firefox 16.0 the option to accept a certificate anyway when present with a "This Connection is Untrusted" message by firefox has disappeared. There is now no way I can actually continue to the web site (https) in question. there should be a button to "continue anyway" this behaviour is on winxp sp3

on linux (slackware 14.0) the site opens fine without any certificate warning or complaints.! on winXpsp3 with firefox 15.1 site opens fine without certificate warning.

comparing with another browser (ie8) which warns, but gives option to continue

since upgrading to firefox 16.0 the option to accept a certificate anyway when present with a "This Connection is Untrusted" message by firefox has disappeared. There is now no way I can actually continue to the web site (https) in question. there should be a button to "continue anyway" this behaviour is on winxp sp3 on linux (slackware 14.0) the site opens fine without any certificate warning or complaints.! on winXpsp3 with firefox 15.1 site opens fine without certificate warning. comparing with another browser (ie8) which warns, but gives option to continue

Valgt løsning

having looked at the html of the error message, I have found a custom setting in firefox to restore the previous default behaviour. it is :- browser.xul.error_pages.expert_bad_cert which needs to be changed to "true" this restores the "add exception" button. It does not explain why an exception is needed when the certificate appears to check out ok, so that may still be a problem, but at least there is a work-arround for the change in default behaviour. I can see this new default behaviour causing problems for new intranet installs. It would be nice if the behaviour was restored to how it was in 15.0.1

Læs dette svar i sammenhæng 0

Yderligere systemdetaljer

Berørte websteder

https://blog.getfirebug.com/2012/10/09/firebug-1-10-4/#respond

Installerede plugins

  • Shockwave Flash 11.4 r402
  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • 4.1.10329.0
  • VLC media player Web Plugin 2.0.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • 1.9.0009.1
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Windows Multimedia Services DRM Store Plug-In

Program

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

Yderligere information

firefox 16.0 winxpsp3 has problem. firefox 15.1 winxpsp3 does not have problem.

Luk
cor-el
  • Top 10 Contributor
  • Moderator
17477 løsninger 157949 svar

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

If such a page opens in an (i)frame then you may not be able to add a exception. You can use the right-click context menu in the browser window to verify that.

It shouldn't be necessary to create an exception for the link that you provided.

You can inspect the certificate chain via a site like this:


Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar. *https://support.mozilla.org/kb/Secure+Connection+Failed If such a page opens in an (i)frame then you may not be able to add a exception. You can use the right-click context menu in the browser window to verify that. It shouldn't be necessary to create an exception for the link that you provided. You can inspect the certificate chain via a site like this: *http://www.networking4all.com/en/support/tools/site+check/ ---- Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored. If that helped to solve the problem then you can remove the renamed cert8.db.old file.<br /> Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.<br /> Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.<br />

Spørgsmålsstiller

using the tool, the web url checks out ok, renaming the cert8.db as you suggested makes no difference. firefox still does not give the option to continue/add exception/certificate. see clipped screenshot attached.

using the tool, the web url checks out ok, renaming the cert8.db as you suggested makes no difference. firefox still does not give the option to continue/add exception/certificate. see clipped screenshot attached.

Ændret af timsoft den

cor-el
  • Top 10 Contributor
  • Moderator
17477 løsninger 157949 svar

Did you check the date and time in the clock on your computer?

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

Did you check the date and time in the clock on your computer? Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

Spørgsmålsstiller

time and date are fine. I'll check safe-mode with networking and report back.

well running in safe-mode with networking still gives the same behaviour

I should mention I have now upgraded to firefox 16.0.1 (but still same behaviour)

time and date are fine. I'll check safe-mode with networking and report back. well running in safe-mode with networking still gives the same behaviour I should mention I have now upgraded to firefox 16.0.1 (but still same behaviour)

Ændret af timsoft den

Valgt løsning

having looked at the html of the error message, I have found a custom setting in firefox to restore the previous default behaviour. it is :- browser.xul.error_pages.expert_bad_cert which needs to be changed to "true" this restores the "add exception" button. It does not explain why an exception is needed when the certificate appears to check out ok, so that may still be a problem, but at least there is a work-arround for the change in default behaviour. I can see this new default behaviour causing problems for new intranet installs. It would be nice if the behaviour was restored to how it was in 15.0.1

having looked at the html of the error message, I have found a custom setting in firefox to restore the previous default behaviour. it is :- browser.xul.error_pages.expert_bad_cert which needs to be changed to "true" this restores the "add exception" button. It does not explain why an exception is needed when the certificate appears to check out ok, so that may still be a problem, but at least there is a work-arround for the change in default behaviour. I can see this new default behaviour causing problems for new intranet installs. It would be nice if the behaviour was restored to how it was in 15.0.1

Spørgsmålsstiller

i think the problem of why I was being asked about the certificate at all was due to an older mozilla certificate exception I had for a different mozilla site. I believe that its certificate was being used in preference to the correct certificate. I removed all mozilla related certificate exceptions and then could get on the relevant web page without any security/certificate prompts at all.

i think the problem of why I was being asked about the certificate at all was due to an older mozilla certificate exception I had for a different mozilla site. I believe that its certificate was being used in preference to the correct certificate. I removed all mozilla related certificate exceptions and then could get on the relevant web page without any security/certificate prompts at all.