Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

about:home search engine not working

  • 21 svar
  • 15 har dette problem
  • 6458 visninger
  • Seneste svar af Shingetsu

more options

When I attempt searching in about:home it fails. It seems to be a JS error since the html form appears quite valid. My aboutHome.js is here: http://pastebin.com/muSihvGt . As can be seen below, I'm on linux 3.2.0-29-generic , 64 bit. In Aurora.

Valgt løsning

The problem seems to be that you can't initialize the chromeappsstore.sqlite file properly.

Deleting the chromeappsstore.sqlite and resetting the browser.startup.homepage_override.mstone pref and restarting Firefox should normally fix this, but in you case even a manual edit doesn't work.

This is the data that I get if I use Copy Row(s) to SQL in the right-click context menu with the SQLite Manager extension.


INSERT INTO "someTable" VALUES ("emoh.:moz-safe-about","search-engine","{""name"":""Google"",""searchUrl"":""https://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-aurora""}","0",null);

CREATE TABLE webappsstore2 (scope TEXT, key TEXT, value TEXT, secure INTEGER, owner TEXT)
Læs dette svar i sammenhæng 👍 1

Alle svar (20)

more options

What happens when you try to search. No response?

Is there a script error in the Error Console (Tools > Web Developer)? To isolate issues related to a particular website function, I suggest the following:

(1) Click the Clear button in the console
(2) Reload the page
(3) Check for Errors (use the Error button to filter out the noise)
(4) Submit your search
(5) Check for Errors

more options

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

more options

Thanks, wasn't aware of that feature, took note of it. However it came out uneventful (no errors). @ jscher

Ændret af Shingetsu den

more options

@Cor-el , It was the 1st thing I attempted ( browser.startup.homepage_override.mstone ). After deleting chromeappsstore.sqlite and letting firefox re-generate it, the problem persists.

more options

How is the about:home search engine being reported?

You can inspect the current search engine via this code in the Web Console panel with the about:home page on display.
Paste this code in the command line that gets selected when you open that panel via Firefox > Web Developer > Web Console or Ctrl+Shift+K.


localStorage["search-engine"]

Copy the result via the right-click context menu to the clipboard and paste it here.


I see this:

"{\"name\":\"Google\",\"searchUrl\":\"https://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}"

Ændret af cor-el den

more options

@cor-el it seems you found it, I get "undefined". Which is in itself weird since in about:config I have: browser.search.order.1;Google browser.search.selectedEngine;Google

I tried manually setting it in the Console (with the \ breaks), but unfortunately it is not persistent (doesn't work after set before restart and I have firefox dump tmp files upon close which may explain it not staying post-restart, though it may be made to do that)

more options

In the web console you can use this:

localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";

If this doesn't stay then you may have (security) software that is preventing Firefox from saving the data in the chromeappsstore.sqlite file properly.

more options

As I've stated previously, I'm on Aurora Linux (x86_64). There's no security software needed here as long as I don't install random packages... And when I feel I have to I scan them with an on-demand scanner and/or look at source. However I *do* have firefox clear tmp files on each restart. Also, changing that field (and checking and seeing it changed) did not affect about:home before restart.

more options

You can use the SQLite Manager to inspect the chromeappsstore.sqlite file and check if the content gets removed after a restart.

more options

Actually, I was just about to write about that -> I've used sqlitebrowser (I'm more comfortable with a terminal). chromeappsstore.sqlite was empty. I tried adding a value that the owner was "search-engine" and marked all the other fields as the above (I knew it was "owner" by analyzing the log of the database. It seems that when I try to get the value of localStorage["search-engine"] firefox looks in the DB, but writing to it only happens in memory) (but without \ parsing as the DB was UTF-8). It managed to stay there (after a restart I checked back), however, the value of localStorage["search-engine"] still returns "undefined".

more options

I recently posted some code on the Contributors forum to be used in the Error Console.

You can give that a try as well.

Note that it isn't simply creating a search-engines entry, but also have set the scope value of that entry to emoh.:moz-safe-about

Ændret af cor-el den

more options

Upon attempting that I recieved the following error: "Error: TypeError: defaultEngine is null"

As I said, chromeappsstore.sqlite is entirely *empty* except for the one field I added manually. It seems that there's either a parsing problem or something similar.

more options

Try this extension to reset the default search engine:

more options

Apparently, it did not work. It's supposed to uninstall after doing so and it didn't, about:home not fixed either. It seems it probably ran into the same error.

Weird fact -> my brand new arch install had no such problem.

more options
more options

I have a few special about:config settings to clear all temp data and remnants (e.g. cookies and all) in place... oh well, I guess it's worth trying.

more options

And no result from that either. Can someone just point me towards the location of about:home locally, so I can modify it? I'm sure making the form plain html (I only want google to be honest) shouldn't be that hard!

more options

Valgt løsning

The problem seems to be that you can't initialize the chromeappsstore.sqlite file properly.

Deleting the chromeappsstore.sqlite and resetting the browser.startup.homepage_override.mstone pref and restarting Firefox should normally fix this, but in you case even a manual edit doesn't work.

This is the data that I get if I use Copy Row(s) to SQL in the right-click context menu with the SQLite Manager extension.


INSERT INTO "someTable" VALUES ("emoh.:moz-safe-about","search-engine","{""name"":""Google"",""searchUrl"":""https://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-aurora""}","0",null);

CREATE TABLE webappsstore2 (scope TEXT, key TEXT, value TEXT, secure INTEGER, owner TEXT)

Ændret af cor-el den

more options

Ok, entering data into SQL manually including emoh.moz-safe-about seems to have worked. Can you list the local location of about:home for future reference though?

more options

Can you list the local location of about:home for future reference though?

If you View Source on about:home, you can see the "location" in the title bar. It is generated from a template in the omni.ja file.

  1. 1
  2. 2