Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Every time i open a new tab babylon search opens up! i tried looking for it in add ons but itsnot in there! I want my blank new tab page back! PLEASE HELP!

  • 6 svar
  • 18 har dette problem
  • 2 visninger
  • Seneste svar af Babylon.Ltd

more options

Ok so i download something and the stupid babylon toolbar downloanded with it and it changed my new tab home page i cant change it im havibng to much trouble!! its not in extensions or add ons im loosing it someone please help me!!!!

Alle svar (6)

more options

You might already have removed the toolbar, but there is a little more cleanup to do.

Try clearing all Babylon references from your preferences using Firefox's about:config preferences editor:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste babylon and pause while the list is filtered

(3) Right-click each reference that contains babylon and choose Reset to return to Firefox's default value.

Then test to see whether your new tab page works normally again.

If Babylon comes back, you might not have removed its extension, or it could be masquerading under an unfamiliar name.

more options

By the way, if you don't like having thumbnails of frequently/recently used pages in your new tabs, you can switch back to having a completely blank tab. It's a fairly quick change in the about:config preferences editor. The steps are listed in this article:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

(i) Page thumbnails (default)

browser.newtab.url = about:newtab

(ii) Blank tab

browser.newtab.url = about:blank

(iii) Built-in Firefox home page

browser.newtab.url = about:home

(iv) Any other page

browser.newtab.url = full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

more options
more options

Dear KelseyNicole12:


In order to change your search engine, please view this link: http://support.babylon.com/index.php?/Knowledgebase/Article/View/213/0/remove-toolbar-and-search-the-web-babylon

(scroll down for Mozilla firefox)


Babylon Offers a full service for all its products and features valid from the Babylon Store and on the world wide web You can gain a full support and assistance on how to remove Babylon from your computer by the following ways :


Phone-18668086361 (US) Email: Support@babylon.com Website for Chat and Q& A : http://support.babylon.com/

Cheers Babylon,Ltd

more options

1. click into the address bar in Firefox.......Type "about:config"

2. You will get a warning about your warranty.....bypass this.

3. In the next screen....type......"Babylon" in the Filter window (a search in the config)

4. You are now in the guts of Firefox.....and where Babylon did it's dirty work. You will find about 5 or six places where Babylon shows up.

5. Highlight each of these entries one at a time, right click and pick "reset".

6. When all have been reset.....close the file. I had a whole mess of babylon listings, just the first 5 needed to be reset

more options

Go to Control Panel, click Programs (software).

Uninstall "Browser Manager" + "Bprotector" + "Object Installer" + "Babylon Toolbar on IE"

Then on your browser , follow the relevant steps:


Firefox ---------------------------

> Open a new Firefox window (website)

> Go to Tools> Options> and go to change your order, the Home. ( f.e www.google.de) and click OK.

> Remove the search engine of Babylon by clicking the small arrow next to the icon of Babylon

> Manage Search Engines

> select Babylon and Remove

> Close Firefox and open again

> write in the address Bar "about:config " and click Enter

> Write in the search engine "Babylon."

> Click on any 'Babylon' preferences with the right mouse button and select "Reset"

In the following video you can see how to change TAB URL :

http://www.youtube.com/watch?v=4yPX-ZJ5fQc&feature=related