Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

400 Bad Request HTTPS over Vital Security Proxy FF 10.0.1, 1o.0.2

  • 3 svar
  • 1 har dette problem
  • 1 visning
  • Seneste svar af ftibi

more options

I use Firefox on W7 in the office. Our company uses a Proxy from Vital Security for Internet access. After upgrading from FF 9.0.1 to FF 10 (including 10.0.2), I have problems accessing HTTPS sites. The proxy returns the following error message:

   HTTP Error Status: 400 Bad Request
   Error Reason: Malformed HTTP request

It still works without any problems from IE or after downgrading to FF 9, so it's definitely a FF 10 issue.

Ændret af ftibi den

Valgt løsning

Update: the problem disappeared without me changing anything (FF 10.0.2). Most likely there was a problem on the proxy itself rejecting valid requests for some reason, maybe having problem with the user agent in the filtering rules. So it was not a Firefox problem. Thanks for your support.

Læs dette svar i sammenhæng 👍 0

Alle svar (3)

more options

That issue can be caused by corrupted cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"
more options

Hi cor-el

I tried the indicated steps (cleaned cache and cookies completely), unfortunately it still doesn't work. I cannot imagine what causes the issue - it works without proxy and it only gets the bad HTTP request on certain HTTPS requests. If you have more ideas, pls. let me know - I am happy to try them out.

more options

Valgt løsning

Update: the problem disappeared without me changing anything (FF 10.0.2). Most likely there was a problem on the proxy itself rejecting valid requests for some reason, maybe having problem with the user agent in the filtering rules. So it was not a Firefox problem. Thanks for your support.

Ændret af ftibi den