Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YOU DON'T MAKE A COMPATIBLE FIREFOX4 FOR MAC OS 10.4.11 AND LOWER SO STOP BUGGING ME TO UPGRADE!!!

more options

Before you start hounding the crap out of users to upgrade to your latest version of Firefox, try to consider that not every user is loaded and sporting the latest OS and apps on their computers. In fact the unemployment rate - just those still receiving unemployment benefits (all those who have exhausted benefits are not counted)- is at an all time high so I think I am not alone in complaining that you have not made an upgrade of your product that is compatible with older operating systems. Yet I get constant reminders to upgrade to your latest version, which I can't and it pisses me off!

Before you start hounding the crap out of users to upgrade to your latest version of Firefox, try to consider that not every user is loaded and sporting the latest OS and apps on their computers. In fact the unemployment rate - just those still receiving unemployment benefits (all those who have exhausted benefits are not counted)- is at an all time high so I think I am not alone in complaining that you have not made an upgrade of your product that is compatible with older operating systems. Yet I get constant reminders to upgrade to your latest version, which I can't and it pisses me off!

Alle svar (1)

more options

How about upgrading to Firefox 3.6.17, which is compatible with 10.4?



BTW, being a little more pleasant when requesting help doesn't cost you anything.