Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 will not install on my ppc mac. If the software is not compatible with my hardware, don't you think you ought to quit telling me to try it?

more options

What details could you possibly need?

Valgt løsning

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

Læs dette svar i sammenhæng 👍 1

Alle svar (5)

more options

Valgt løsning

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

more options

I understand. My issue is not that I want to run Firefox 4.0, but that I was encouraged to install it, did so with no warning that it was not compatible until I tried to run it and had to remove it and get my original Firefox from backup. That's annoying. It would not hurt to warn those of us who cling to our ppcs that we should not install Firefox 4, or that we could get a ppc version somewhere else. That's all I was trying to say.

more options

Yes, we're preparing changes to so Firefox 4 will not be offered to users whose Macs won't run the new version.

For details, see:

Ændret af Matt Brubeck den

more options

How can I get an older/my original version back if I don't have it backed up?!?!

more options

You can download the previous version from http://www.firefox.com/all-older.html