Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

links are not underlined

  • 2 svar
  • 42 har dette problem
  • 1593 visninger
  • Seneste svar af greenhome

more options

I've been creating a new website, using css for changing the appearance of my links and one of the things I want is for the links to always be underlined.

The links appear underlined in Safari and on other people's computers which use IE, but not in Firefox.

Apart from the colours used, this is the same css code as I used in my other website, where I don't have that problem at all.

Valgt løsning

You do have a few stylesheets that specify what to do with links. The last stylesheet sets visited links to text-decoration:none, so links that have been visited are no longer underlined.

<style type="text/css">a:link { color: #3366cc; text-decoration: underline }a:visited { color: 660000; text-decoration: none }a:hover { color: #ffcc66; text-decoration: underline }a:active { color: #ff6600; text-decoration: none }</style></p><p><style type="text/css">h1,h2,h3,h4 { color: #660000 }</style>

See also Firefox > Preferences > Content : Fonts & Colors > Colors: Underline links

Læs dette svar i sammenhæng 👍 3

Alle svar (2)

more options

Valgt løsning

You do have a few stylesheets that specify what to do with links. The last stylesheet sets visited links to text-decoration:none, so links that have been visited are no longer underlined.

<style type="text/css">a:link { color: #3366cc; text-decoration: underline }a:visited { color: 660000; text-decoration: none }a:hover { color: #ffcc66; text-decoration: underline }a:active { color: #ff6600; text-decoration: none }</style></p><p><style type="text/css">h1,h2,h3,h4 { color: #660000 }</style>

See also Firefox > Preferences > Content : Fonts & Colors > Colors: Underline links

more options

Thank you for solving this mystery! That single example of an old css code was in a right column, the only place I hadn't checked, and apparently Firefox for Mac gives prioriry to that column over the main text area, whereas Safari gives priority to the main content area.

Gina