Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I change the default Outlook mailto: account

more options

I just upgraded to a new computer with Windows 7 and Outlook 2010. I'm running Firefox 3.6.9.

When I right click on a website and choose "Send link", Firefox correctly uses Outlook as the email client. However, I have several accounts configured in Outlook (gmail, my work account, my ISP account, etc) and the account Firefox uses is not the one I want to use. I want my gmail account to be the default, not my work account which is what it uses.

Outlook is correctly configured to have my gmail account as my default address. For example, if I choose "New email" from within Outlook, the account it uses is my gmail account. If I want to use another account, I have to manually change it.

I want my Firefox Mailto: to work the same way. I can't find anything within Firefox that allows me to specify which account Outlook uses; Outlook itself is set to use gmail as the default account; what am I doing wrong?

Valgt løsning

So I have fixed it to work how I want it to. It might work for you but if you use calendars outside of Outlook it might mess with some settings there. I just went to control panel and mail. Went to Data files and there I saw that my Exchange account data file was set as default. I set Outlook.pst as default, ignored the box that popped up warning about to do tabs, etc and now when I click a link in Firefox, it sends email using my Default email account that is set in Outlook. Thanks for directing me to the clue!

Læs dette svar i sammenhæng 👍 1

Alle svar (10)

more options

Check the Mailto setting: Tools > Options > Applications : Mailto

See also http://kb.mozillazine.org/Default_mail_client

more options

Did you find a fix for this issue? I am having the same problem. Firefox does not use my default email account to send - I have to manually switch it everytime.

more options

I haven't found a fix yet, but have found more info on the issue. It's not a Firefox issue - it's an Outlook settings issue. This thread explains what's going on, but so far no solution. Please let me know if you find one!

http://www.outlookforums.com/showthread.php?69015-Outlook-2010-Multiple-Accounts-amp-Default-Account

more options

Valgt løsning

So I have fixed it to work how I want it to. It might work for you but if you use calendars outside of Outlook it might mess with some settings there. I just went to control panel and mail. Went to Data files and there I saw that my Exchange account data file was set as default. I set Outlook.pst as default, ignored the box that popped up warning about to do tabs, etc and now when I click a link in Firefox, it sends email using my Default email account that is set in Outlook. Thanks for directing me to the clue!

more options

That worked for me too! Thanks for posting... I figured it was probably something that could be fixed but have had little time to spend on investigating it.

more options

Glad to hear it. I had been searching for a couple of days before I found this post. Thanks for the help!

more options

Update - when I actually tried to send the email it froze up. Not sure if this was because the account that I was trying not to use was an Exchange account but something is just not right yet. I had to switch back to having my Exchange account as default data file for now until I figure out what is going on. Where you able to actually send an email from Firefox? The only way I could get it to go was to save as draft, open outlook and then send which is more work that just selecting the account to send from.

more options

Mine worked just fine. Tested it a few times this morning.

more options

I just added firefox and am using it now instead of explorer. When I open a link that i have received inside of my outlook program the explorer opens instead of firefox.

How can i set outlook to use firefox instead of internet explorer?

Thanks

more options

Yep worked.. thanks for the help.