Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does the Firefox Start page keep appearing???

  • 4 svar
  • 22 har dette problem
  • 4 visninger
  • Seneste svar af dragonette

more options

I'm using the latest version of Mozilla Firefox 3.6.8 and when I try to go to view any URL, it suddenly automatically reappears and reverts back to the mozilla firefox start page (http://www.google.com/firefox)! This is really annoying and I can't take much more of this. Even when it's there on the start page it just keeps automatically appearing and reloading itself and won't stop no matter what I do. When I type in another URL it will automatically revert back to this stupid start page within 10 to 30 seconds again.

I did click on the 'Warn me when web sites try to redirect or reload the page' but that didn't do anything.. or, perhaps it even made it reload this stupid start page even faster!

Am I the ONLY person having this problem???

PLEASE help me or I will just uninstall this software and use something else for browsing the net. TW

Alle svar (4)

more options

Is it possible that, rather than actually going to the home page, Firefox is going back a page? If that's the case (you can test it by seeing if a new tab has the same problem, as it's impossible to go back in a tab without history), I'd suggest you check your mouse or keyboard drivers, as it's possible that some drivers keep going unwanted instructions to the browser, wrongly making it go back (or doing unwanted stuff).

In any case, it's also possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

more options

Morbus,

I think you may be correct that it may be caused by an add-on because when I disabled them all I don't have that problem anymore. Now I'm enabling them one by one to try and figure out exactly which one it is.

Will let you know when I figure it out.

TW

more options

Hi, I tried disabling all of my addons and the problem remains.... see my next post!

Ændret af dragonette den

more options

PROBLEM SOLVED!!!! In the "options" menu where you choose your home page, make sure you have ONLY the page you want open. If you have several pages open Firefox will make ALL of those open pages your home page(s).