Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Second level google searches broken in multiple firefox versions when not signed into google accounts and starting search is from www.google.com/

  • 23 svar
  • 21 har dette problem
  • 128 visninger
  • Seneste svar af jblo41

more options

Hey there, I don't know if you have noticed this, but in Firefox, old and new versions alike, trying to do a search on a resulting page while not being logged into a google account does nothing.

If you search from www.google.com while not signed into their google accounts, the resulting page no longer allows you to use another search.

Tried hitting enter, nothing. tried hitting the search button, nothing.

Switched to the pc next to me, same results.

asked multiple coworkers to do the same thing and they all had similar results. This is across platforms. PPC macs, newer intel based macs, pcs.

I went to www.google.com and searched for "this is ok"

which sent me to: http://www.google.com/#hl=en&source=hp&q=this+is+ok&aq=f&aqi=g1&aql=&oq=&gs_rfai=C5rII5XIuTI7YOIXyzASyxoD_CwAAAKoEBU_QYOqu&fp=36ec6be010d257f

I then typed in "this is not"


The query string changes but nothing happens... I'm now at my box at home and it's an even DIFFERENT version of Firefox. It's not breaking in IE or chrome. 3.5.8 and up causing problems.

It seems to be a bit of their code that they changed which is doing it. I'm not using any addons or plugins. but on a different computer, I had a console open and here was the error:

F.prototype._rce=function(a,b) ;F.prototype._rd=function(a,b,c) ;F.prototype._t=function() ;F.prototype._rt=function() ;F.prototype._i=function(a) ;F.prototype._c=function() };F.prototype._ns=function() ;

reference to undefined property c[a] on line 50...

I hope Google isn't trying to break Firefox! :(

URL of affected sites


Alle svar (3)

more options

Google still broken!!!

more options

I have experienced this very same problem recently with FF 3.6.8

Several things were temporary work arounds, like using iGoogle or

https://www.google  or turning off java script.  But these are not great.

I fixed the problem by running Ccleaner


I noticed that ccleaner deleted the 'downloads.sqlite' file from my FF profile directory. That file may have been the root of the problem since Mozilla was suggesting that the problem may be in the formhistory.sqlite file.


more options

Just after posting this last reply, I think I accidentally ran across the real answer.

I thought that I fixed the problem running Ccleaner, but then I did a 'restart' (using the restart FF command on the 'File' menu) and the problem with the Google search button showed up again.

I then deleted all my Google related tabs, cleared the Cache and closed FF completely and started it from my Desktop Icon. The Google search button began to work again.

I repeated this 3 times. Every time I did a restart of FF from within FF, the Google search button stopped working. And then I fixed it by deleting any Google related tabs, clearing the Cache and closing FF altogether and starting it up from Windows (Vista).

Something to look out for because FF asks you to 'Restart' FF from within FF a lot these days. Whenever you update anything.


  1. 1
  2. 2