Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the google homepage search bar does not work with the latest firefox upgrade. the google toolbox works. it is not specific to my computer.

  • 24 svar
  • 0 har dette problem
  • 16 visninger
  • Seneste svar af Chris Ilias

more options

the google homepage is not working with today's firefox upgrade. the google toolbox works. it is not specific to my computer.

URL of affected sites


the google homepage is not working with today's firefox upgrade. the google toolbox works. it is not specific to my computer. == URL of affected sites == http://www.google.com

Alle svar (20)

more options

Could you provide more detail than "does not work"? Does the page load? Can you enter text? When you press the search button, what happens?

more options

I'm having the same problem, I enter some text and try to search, nothing happens. I've attached a screenshot of a search I tried to do. This is after I clicked on the search button.

more options

I have the same issue. The Google homepage loads fine. I can enter text into the search field, but when I click 'search' nothing happens. I can click 'I'm feeling lucky' and it will work. The Google search bar in the top right also works normally. I'm running XP SP3 and FF 3.6.6

more options

when you enter a word in the browser text box you get the list of suggested sites--that's works ok. but when you actually select a site or put a search term in the text box and hit "google search" nothing happens. if you hit "i'm feeling lucky" you will get a hit. hope this helps.

more options

I DID NOT reply to Dave, not sure how my name got there!!! Something is wrong here.

more options

The problem was due to Network Settings. I had chosen 'Use System Proxy Settings', which caused the problem, although its a little weird as to why other websites had no issues and even searching via google toolbar worked fine. I changed to Manual Proxy Settings and entered proxy information, now google search works fine.

more options

I started experiencing the same problem yesterday. Not sure why, but it appears Google is currently serving up a bad version of the Google homepage to Firefox users. (The Google homepage works fine in IE and Chrome.) I have discovered that if you override the user-agent via about:config and remove Firefox from it, the Google homepage works again.

This is problem is really Google's, but here is a temporary workaround so you can have the Google homepage up and working again:

1. Type "about:config" in the Firefox address bar 2. Right click within the list and choose New -> String 3. Enter general.useragent.override as the preference name 4. Enter some value. It could be blank or you could visit a website such as http://show-ip.net/browserinfo/, get your current user agent and remove the Firefox entry.

For example, my user agent was:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20100625 Firefox/3.6.6 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)

Taking out the Firefox/3.6.6 entry leaves me with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20100625 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)

After you finish making those changes the google homepage should be working again.

Note: When Google fixes this problem it would be a good idea to revert the user agent override by right clicking on "general.useragent.override" and choosing "Reset".

Related issue: https://support.mozilla.com/en-US/for.../714471

more options

Had the same problem today after I updated FireFox to 3.6.6.

1st search would work fine in Google, then any subsequent search would let me type in but the search wouldn't work and trying to chose options for narrowing search on the left wouldn't work either. However, hitting refresh would allow it to work. However, other search engines work fine and other browsers work fine with Google so I'm thinking others are right about Google having some bad code today.

Thank you Zach for the info on the about:config, works perfectly now.

more options

Having same problem on both my computers with Firefox and google. hit enter in the search bar and nothing happens. This just started today. I am not having the problem with Internet Explorer.

more options

I have the same thing...the intial google screen works for me, but once i search on something i cannot get google to respond unless I go back to the homepage for google.

more options
more options

Browser: Firefox 3.6.6 Laptop: HP Operating System: Windows XP Professional Homepage: Google Cleaned cookies, cache, etc: Yes Tried Firefox safe mode with add-ons disabled: Yes

I think this became a problem yesterday. I was able to search after the initial search on Google when I was not using private browsing. When I used private browsing, I was only able to search the first time. When I changed the keywords and pressed enter or clicked on the search button, nothing changed but the url in the address bar. It would not go to the new search unless I refreshed the page. I decided to use Firefox normally, without private browsing, but the same thing happened after a while.

I have noticed that when I do the initial search, the title of the tab (or window) is not the term I searched, but rather "http://www.google...7b4a8f300686322e" (or some other batch of numbers and letters). When I do the initial search using the Firefox search engine bar, the title is "search keyword - Google Search."

Initial search from Google homepage using the keyword hello: http://www.google.com/#hl=en&source=hp&q=hello&aq=f&aqi=g10&aql=&oq=&gs_rfai=CxpNrx-MuTJ_4AqX4MbrIia4KAAAAqgQFT9CAVwg&fp=7b4a8f300686322e

Initial search from Google homepage using the keyword hello but typing it in the Firefox search engine bar: http://www.google.com/search?q=hello&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

What I have been doing to counter this issue is do the initial search using the search engine bar that is to the right of the address bar. After I do the initial search, I am able to search again but without suggestions. I am able to do this as long as I do not go to another website by entering the url in the address bar.

I hope this bug gets fixed soon.

more options

Ditto ... V3.6.6, same exact problem here too. I should have checked this site first before I did a system restore which, BTW, did not help. OMG back to IE! Please fix ...

more options

First search works fine. Additional searches do nothing. Have to go back to www.google.com and type in the new search.

more options

Which one of you is the person who originally started this thread?

more options

I have the same problem. None of the buttons on the Google toolbar work. Not even the uninstall!

more options

The same problem, in my case the toolbar is not showing any button. And I cant unistall

more options

I have the same problem, but in my case I can´t see any button of the toolbar. See Image attached

more options

Same problem.

Firefox, (at least).

Going to http://www.google.com/ adding "searchterm" to seach box and clicking "Google Search" button results only in a change to URL (no search results, still on homepage)


more options

Unless you are the person who started this thread, it is best to start your own thread, so you get help that is specific to your setup. Thanks. Just go to https://support.mozilla.com/forum/1?openpost=1

  1. 1
  2. 2