X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Shift symbol keys are misinterpreted in one of two accounts, but correct in the other.

Skrevet

Have admin & guest accounts on computer. Firefox works properly in admin acct, but in guest acct. it doesn't fill in forms correctly, e.g. typing @ yields ", # = ., ^ = &, & = / and so forth. Problem is confined to special characters, alpha (lower & upper case) & numbers are correct.

This happened

Every time Firefox opened

== unsure, as guest acct. rarely used for interaction

Have admin & guest accounts on computer. Firefox works properly in admin acct, but in guest acct. it doesn't fill in forms correctly, e.g. typing @ yields ", # = ., ^ = &, & = / and so forth. Problem is confined to special characters, alpha (lower & upper case) & numbers are correct. == This happened == Every time Firefox opened == unsure, as guest acct. rarely used for interaction

Valgt løsning

It is possible that you accidentally switched the keyboard layout (en-GB?).

Make sure that you have the Language bar visible on the Windows Taskbar. You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar. See: http://support.microsoft.com/kb/306993 - HOW TO: Use the Language Bar in Windows XP http://windows.microsoft.com/en-US/windows-vista/The-Language-bar-overview - The Language bar (overview) .... You can check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar, so you need to do that while Firefox has focus. Windows remembers that setting per application and the default is a key combination (Ctrl+Shift or Alt+Shift) that you can easily use in Firefox to activate a menu item. Disable the key sequence to rotate layouts (Alt+Shift or Ctr+Shift) to avoid an unintentional switch and instead assign a specific key (Alt/Ctrl+Shift+number) to switch to the keyboard layout.

For XP see: Control Panel > Regional and Language Options > Languages > Text services and input languages > Details > Key Settings > Change Key Sequence For Vista see: Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

Læs dette svar i sammenhæng 0

Yderligere systemdetaljer

Installerede plugins

  • -np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 3.0.50106.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Java Plug-in 1.6.0_05 for Netscape Navigator (DLL Helper)

Program

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Yderligere information

Default character encoding in both accts. is Western ISO-8859-1

Luk
Chris Ilias
  • Moderator
354 løsninger 1943 svar

Does that happen with other programs on that account?

Does that happen with other programs on that account?
cor-el
  • Top 10 Contributor
  • Moderator
17469 løsninger 157871 svar

Valgt løsning

It is possible that you accidentally switched the keyboard layout (en-GB?).

Make sure that you have the Language bar visible on the Windows Taskbar. You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar. See: http://support.microsoft.com/kb/306993 - HOW TO: Use the Language Bar in Windows XP http://windows.microsoft.com/en-US/windows-vista/The-Language-bar-overview - The Language bar (overview) .... You can check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar, so you need to do that while Firefox has focus. Windows remembers that setting per application and the default is a key combination (Ctrl+Shift or Alt+Shift) that you can easily use in Firefox to activate a menu item. Disable the key sequence to rotate layouts (Alt+Shift or Ctr+Shift) to avoid an unintentional switch and instead assign a specific key (Alt/Ctrl+Shift+number) to switch to the keyboard layout.

For XP see: Control Panel > Regional and Language Options > Languages > Text services and input languages > Details > Key Settings > Change Key Sequence For Vista see: Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

It is possible that you accidentally switched the keyboard layout (en-GB?). Make sure that you have the Language bar visible on the Windows Taskbar. You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar. See: http://support.microsoft.com/kb/306993 - HOW TO: Use the Language Bar in Windows XP http://windows.microsoft.com/en-US/windows-vista/The-Language-bar-overview - The Language bar (overview) .... You can check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar, so you need to do that while Firefox has focus. Windows remembers that setting per application and the default is a key combination (Ctrl+Shift or Alt+Shift) that you can easily use in Firefox to activate a menu item. Disable the key sequence to rotate layouts (Alt+Shift or Ctr+Shift) to avoid an unintentional switch and instead assign a specific key (Alt/Ctrl+Shift+number) to switch to the keyboard layout. For XP see: Control Panel > Regional and Language Options > Languages > Text services and input languages > Details > Key Settings > Change Key Sequence For Vista see: Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence