X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox won't install add-ons even after clean install

Skrevet

Add-on installation fails in one of the following ways:

1. Unexpected installation error -203, or 2. The add-on appears in the "Extensions" tab as "Not compatible with Firefox 3.6.3", even though it is.

Sometimes I get the first error, sometimes the second, but all attempts to install add-ons fail with one of them.

I have tried all the troubleshooting advice in the knowledge bases (e.g. http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox#Unexpected_installation_error_-203) but with no success. I even did a clean reinstall of Firefox in a new directory (as described here: http://kb.mozillazine.org/Uninstalling_Firefox#On_Mac_OS_X) but the problem remains.

What else can I do?

This happened

Every time Firefox opened

I tried to install a new add-on.

User Agent

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.38 Safari/533.4

Add-on installation fails in one of the following ways: 1. Unexpected installation error -203, or 2. The add-on appears in the "Extensions" tab as "Not compatible with Firefox 3.6.3", even though it is. Sometimes I get the first error, sometimes the second, but all attempts to install add-ons fail with one of them. I have tried all the troubleshooting advice in the knowledge bases (e.g. http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox#Unexpected_installation_error_-203) but with no success. I even did a clean reinstall of Firefox in a new directory (as described here: http://kb.mozillazine.org/Uninstalling_Firefox#On_Mac_OS_X) but the problem remains. What else can I do? == This happened == Every time Firefox opened == I tried to install a new add-on. == == User Agent == Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.38 Safari/533.4

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.38 Safari/533.4

Yderligere information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Show in Finder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Modified Preferences
Name
Value
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

Luk
Morbus 135 løsninger 2340 svar

Hello Konstantina.

I believe I've come across the same problem as you, although only the second message. However, my Firefox has its add-on compatibility check disabled, so it doesn't bother me.

The only thing I can tell you is that you may want to disable the compatibility check and force Firefox to use all extensions you install. There are multiple ways to do so. One is to read this page:

http://kb.mozillazine.org/Extensions.checkCompatibility

To know how to change that configuration, read this:

http://kb.mozillazine.org/Editing_configuration

Hello Konstantina. I believe I've come across the same problem as you, although only the second message. However, my Firefox has its add-on compatibility check disabled, so it doesn't bother me. The only thing I can tell you is that you may want to disable the compatibility check and force Firefox to use all extensions you install. There are multiple ways to do so. One is to read this page: http://kb.mozillazine.org/Extensions.checkCompatibility To know how to change that configuration, read this: http://kb.mozillazine.org/Editing_configuration

Spørgsmålsstiller

Dear Morbus,

thank you for the suggestion. Unfortunately it didn't help either. I introduced a new "extensions.checkCompatibility" setting with value "false" but I still get the same "Not compatible with Firefox 3.6.3" message for any new attempts at add-on installation. :(

It's quite puzzling...

Dear Morbus, thank you for the suggestion. Unfortunately it didn't help either. I introduced a new "extensions.checkCompatibility" setting with value "false" but I still get the same "Not compatible with Firefox 3.6.3" message for any new attempts at add-on installation. :( It's quite puzzling...
Morbus 135 løsninger 2340 svar

As it says in the page I liked to, for Firefox 3.6, the old extensions.checkCompatibility doesn't work. You have to create a string that's called "extensions.checkCompatibility.versionNumber" where version number is the version you want to "pretend" to be. Basically, if you put "extensions.checkCompatibility.3.*" it should work. Or even "http://kb.mozillazine.org/Extensions.checkCompatibility.*.*" or something like that.

In the end, the underlying problem may not be solved, but at least you can install extensions. Or should be able to.

As it says in the page I liked to, for Firefox 3.6, the old extensions.checkCompatibility doesn't work. You have to create a string that's called "extensions.checkCompatibility.versionNumber" where version number is the version you want to "pretend" to be. Basically, if you put "extensions.checkCompatibility.3.*" it should work. Or even "http://kb.mozillazine.org/Extensions.checkCompatibility.*.*" or something like that. In the end, the underlying problem may not be solved, but at least you can install extensions. Or should be able to.

Spørgsmålsstiller

Oh sorry, I missed that part earlier. Thanks, now compatibility check is properly disabled.

However, I still cannot install add-ons! The Extensions tab displays on top "Add-on compatibility checking is disabled. You may have incompatible add-ons", and further down shows my add-ons as "Not compatible", exactly as before. (And they are indeed not working!)

Oh sorry, I missed that part earlier. Thanks, now compatibility check is properly disabled. However, I still cannot install add-ons! The Extensions tab displays on top "Add-on compatibility checking is disabled. You may have incompatible add-ons", and further down shows my add-ons as "Not compatible", exactly as before. (And they are indeed not working!)

Spørgsmålsstiller

I even tried to revert to Firefox 3.5.9 but that did not bring anything either...

I even tried to revert to Firefox 3.5.9 but that did not bring anything either...
Morbus 135 løsninger 2340 svar

That is very weird.

I'm not a mac user so that doesn't help either :( I can only thing that, for some reason, something is preventing Firefox from interacting correctly with the profile folder. Some Firewall or something... Other than that, I'm out of ideas, I'm sorry.

That is very weird. I'm not a mac user so that doesn't help either :( I can only thing that, for some reason, something is preventing Firefox from interacting correctly with the profile folder. Some Firewall or something... Other than that, I'm out of ideas, I'm sorry.
dClauzel 0 løsninger 2 svar

I have the same problem : impossible to install or update extensions; either by download (error -228) or by installing a local file (error -203). This is true for all situations : existing or new Firefox profile, different system users, etc.

I searched the kb, asked Google and so, but no solutions worked. The problem happens on all current versions of Firefox : stable, nightly,32 bits and 64 bits.

File extensions.log contains lines of 2010-04-02 21:36:38 - ExtensionManager:_finishOperations - failure, catching exception - lineno: 359 - file: undefined - [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/Web/Firefox.app/Contents/MacOS/components/nsExtensionManager.js :: getDirInternal :: line 359" data: no]

My system is :

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr-FR; rv:1.9.3) Gecko/20100412 Minefield/3.7

 Application Basics
       Name
       Firefox
       Version
       3.7
       Profile Directory
         Show in Finder
       Installed Plugins
         about:plugins
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       Adblock Plus
       1.1.3
       true
        
       Adblock Plus: Element Hiding Helper
       1.0.6
       true
       elemhidehelper@adblockplus.org
       Add-on Collector
       1.1.1
       false
       sharing@addons.mozilla.org
       BetterPrivacy
       1.47
       true
        
       Brief
       1.2.5
       true
       brief@mozdev.org
       British English Dictionary
       1.19
       false
       en-GB@dictionaries.addons.mozilla.org
       BugMeNot
       2.2
       true
       {987311C6-B504-4aa2-90BF-60CC49808D42}
       CustomizeGoogle
       0.76
       true
        
       Dictionary Switcher
       1.0.1
       true
       dictionary-switcher@design-noir.de
       Dictionnaire français «Réforme 1990»
       3.5
       true
       fr@dictionaries.addons.mozilla.org
       Diigo Bookmarks and Web Annotations
       4.1.0.46
       true
        
       Firefox PDF Plugin for Mac OS X
       1.1.3
       true
       colesbury@gmail.com
       FoxyProxy Standard
       2.19.1
       false
       foxyproxy@eric.h.jung
       Get jetable mail
       0.4.1
       true
       {26af1522-982e-c0c4-f54a-7e69fb6432f5}
       It's All Text!
       1.4.1
       true
       itsalltext@docwhat.gerf.org
       Lazarus: Form Recovery
       2.0.5
       true
       lazarus@interclue.com
       Personas
       1.5.2
       true
       personas@christopher.beard
       Tab in Textarea
       0.9
       true
        
       Torbutton
       1.2.4
       false
        
       URL Tooltip
       1.2.1
       true
       url-tooltip@timothytate.net
       User Agent Switcher
       0.7.2
       true
        
       Xmarks
       3.5.7
       true
       foxmarks@kei.com
       Zotero
       2.0.2
       false
       zotero@chnm.gmu.edu
       Image Zoom
       0.4.4
       true
       {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
       Firebug
       1.5.3
       false
       firebug@software.joehewitt.com
 Modified Preferences
     Name
     Value
       accessibility.typeaheadfind.flashBar
       0
       browser.history_expire_days.mirror
       180
       browser.history_expire_days_min
       7
       browser.places.importBookmarksHTML
       false
       browser.places.smartBookmarksVersion
       2
       browser.startup.homepage
       about:mozilla
       browser.startup.homepage_override.mstone
       rv:1.9.3
       browser.tabs.warnOnClose
       false
       dom.disable_window_move_resize
       true
       dom.disable_window_status_change
       false
       dom.event.contextmenu.enabled
       false
       extensions.checkCompatibility
       false
       extensions.checkCompatibility.3.6
       false
       extensions.checkCompatibility.3.6b
       false
       extensions.checkCompatibility.3.7
       false
       extensions.checkCompatibility.3.7a
       false
       extensions.checkCompatibility.3.7a5
       false
       extensions.checkCompatibility.3.7b
       false
       extensions.lastAppVersion
       3.7
       font.minimum-size.x-western
       11
       font.name.monospace.x-western
       DejaVu Sans Mono
       font.name.sans-serif.x-western
       DejaVu Sans
       font.name.serif.x-western
       DejaVu Serif
       general.useragent.extra.betterprivacy
       general.useragent.locale
       fr-FR
       javascript.options.showInConsole
       true
       keyword.URL
       https://[www.google.com]/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=
       network.cookie.prefsMigrated
       true
       network.http.max-connections
       60
       network.http.max-connections-per-server
       30
       network.http.max-persistent-connections-per-server
       8
       network.http.pipelining
       true
       network.http.pipelining.maxrequests
       8
       network.http.pipelining.ssl
       true
       network.http.proxy.pipelining
       true
       network.security.ports.banned
       8118,8123,9050,9051
       places.history.expiration.transient_current_max_pages
       96636
       places.last_vacuum
       1276761638
       print.macosx.pagesetup-2
       PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
       print.print_bgcolor
       true
       print.print_bgimages
       true
       print.print_command
       print.print_downloadfonts
       false
       print.print_evenpages
       true
       print.print_footerleft
       print.print_footerright
       &PT
       print.print_headerleft
       print.print_headerright
       &D
       print.print_in_color
       true
       print.print_margin_bottom
       0.5
       print.print_margin_left
       0.5
       print.print_margin_right
       0.5
       print.print_margin_top
       0.5
       print.print_oddpages
       true
       print.print_orientation
       0
       print.print_pagedelay
       500
       print.print_paper_data
       0
       print.print_paper_height
       11.00
       print.print_paper_size_type
       1
       print.print_paper_size_unit
       0
       print.print_paper_width
       8.50
       print.print_printer
       print.print_reversed
       false
       print.print_scaling
       1.00
       print.print_shrink_to_fit
       true
       print.print_to_file
       false
       print.print_unwriteable_margin_bottom
       57
       print.print_unwriteable_margin_left
       25
       print.print_unwriteable_margin_right
       25
       print.print_unwriteable_margin_top
       25
       privacy.cpd.cookies
       false
       privacy.cpd.formdata
       false
       privacy.cpd.sessions
       false
       privacy.sanitize.migrateFx3Prefs
       true
       privacy.sanitize.timeSpan
       0
       security.crl.autoupdate.dayCnt.
       1
       security.crl.autoupdate.enable.
       true
       security.crl.autoupdate.errCount.
       0
       security.crl.autoupdate.errDetail.
       Download of the CRL failed due to Network problems.
       security.crl.autoupdate.freqCnt.
       1
       security.crl.autoupdate.nextInstant.
       03/07/10 23:00:00
       security.crl.autoupdate.timingType.
       1
       security.crl.autoupdate.url.
       http://crl.certificat.com/DGI/DGI_UsagerB.crl
       security.disable_button.openCertManager
       false
       security.warn_viewing_mixed
       false

I am making heavy use of soft links on my systems : ~/Library/* (temp, cache, preferences, etc) is spread onto several physical volumes, and the filetree is done with soft links. No applications has any problem, except Firefox.

I have the same problem : impossible to install or update extensions; either by download (error -228) or by installing a local file (error -203). This is true for all situations : existing or new Firefox profile, different system users, etc. I searched the kb, asked Google and so, but no solutions worked. The problem happens on all current versions of Firefox : stable, nightly,32 bits and 64 bits. File extensions.log contains lines of <code> 2010-04-02 21:36:38 - ExtensionManager:_finishOperations - failure, catching exception - lineno: 359 - file: undefined - [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/Web/Firefox.app/Contents/MacOS/components/nsExtensionManager.js :: getDirInternal :: line 359" data: no] </code> My system is : <code> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr-FR; rv:1.9.3) Gecko/20100412 Minefield/3.7 Application Basics Name Firefox Version 3.7 Profile Directory Show in Finder Installed Plugins about:plugins Build Configuration about:buildconfig Extensions Name Version Enabled ID Adblock Plus 1.1.3 true Adblock Plus: Element Hiding Helper 1.0.6 true elemhidehelper@adblockplus.org Add-on Collector 1.1.1 false sharing@addons.mozilla.org BetterPrivacy 1.47 true Brief 1.2.5 true brief@mozdev.org British English Dictionary 1.19 false en-GB@dictionaries.addons.mozilla.org BugMeNot 2.2 true {987311C6-B504-4aa2-90BF-60CC49808D42} CustomizeGoogle 0.76 true Dictionary Switcher 1.0.1 true dictionary-switcher@design-noir.de Dictionnaire français «Réforme 1990» 3.5 true fr@dictionaries.addons.mozilla.org Diigo Bookmarks and Web Annotations 4.1.0.46 true Firefox PDF Plugin for Mac OS X 1.1.3 true colesbury@gmail.com FoxyProxy Standard 2.19.1 false foxyproxy@eric.h.jung Get jetable mail 0.4.1 true {26af1522-982e-c0c4-f54a-7e69fb6432f5} It's All Text! 1.4.1 true itsalltext@docwhat.gerf.org Lazarus: Form Recovery 2.0.5 true lazarus@interclue.com Personas 1.5.2 true personas@christopher.beard Tab in Textarea 0.9 true Torbutton 1.2.4 false URL Tooltip 1.2.1 true url-tooltip@timothytate.net User Agent Switcher 0.7.2 true Xmarks 3.5.7 true foxmarks@kei.com Zotero 2.0.2 false zotero@chnm.gmu.edu Image Zoom 0.4.4 true {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68} Firebug 1.5.3 false firebug@software.joehewitt.com Modified Preferences Name Value accessibility.typeaheadfind.flashBar 0 browser.history_expire_days.mirror 180 browser.history_expire_days_min 7 browser.places.importBookmarksHTML false browser.places.smartBookmarksVersion 2 browser.startup.homepage about:mozilla browser.startup.homepage_override.mstone rv:1.9.3 browser.tabs.warnOnClose false dom.disable_window_move_resize true dom.disable_window_status_change false dom.event.contextmenu.enabled false extensions.checkCompatibility false extensions.checkCompatibility.3.6 false extensions.checkCompatibility.3.6b false extensions.checkCompatibility.3.7 false extensions.checkCompatibility.3.7a false extensions.checkCompatibility.3.7a5 false extensions.checkCompatibility.3.7b false extensions.lastAppVersion 3.7 font.minimum-size.x-western 11 font.name.monospace.x-western DejaVu Sans Mono font.name.sans-serif.x-western DejaVu Sans font.name.serif.x-western DejaVu Serif general.useragent.extra.betterprivacy general.useragent.locale fr-FR javascript.options.showInConsole true keyword.URL https://[www.google.com]/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= network.cookie.prefsMigrated true network.http.max-connections 60 network.http.max-connections-per-server 30 network.http.max-persistent-connections-per-server 8 network.http.pipelining true network.http.pipelining.maxrequests 8 network.http.pipelining.ssl true network.http.proxy.pipelining true network.security.ports.banned 8118,8123,9050,9051 places.history.expiration.transient_current_max_pages 96636 places.last_vacuum 1276761638 print.macosx.pagesetup-2 PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO… print.print_bgcolor true print.print_bgimages true print.print_command print.print_downloadfonts false print.print_evenpages true print.print_footerleft print.print_footerright &PT print.print_headerleft print.print_headerright &D print.print_in_color true print.print_margin_bottom 0.5 print.print_margin_left 0.5 print.print_margin_right 0.5 print.print_margin_top 0.5 print.print_oddpages true print.print_orientation 0 print.print_pagedelay 500 print.print_paper_data 0 print.print_paper_height 11.00 print.print_paper_size_type 1 print.print_paper_size_unit 0 print.print_paper_width 8.50 print.print_printer print.print_reversed false print.print_scaling 1.00 print.print_shrink_to_fit true print.print_to_file false print.print_unwriteable_margin_bottom 57 print.print_unwriteable_margin_left 25 print.print_unwriteable_margin_right 25 print.print_unwriteable_margin_top 25 privacy.cpd.cookies false privacy.cpd.formdata false privacy.cpd.sessions false privacy.sanitize.migrateFx3Prefs true privacy.sanitize.timeSpan 0 security.crl.autoupdate.dayCnt. 1 security.crl.autoupdate.enable. true security.crl.autoupdate.errCount. 0 security.crl.autoupdate.errDetail. Download of the CRL failed due to Network problems. security.crl.autoupdate.freqCnt. 1 security.crl.autoupdate.nextInstant. 03/07/10 23:00:00 security.crl.autoupdate.timingType. 1 security.crl.autoupdate.url. http://crl.certificat.com/DGI/DGI_UsagerB.crl security.disable_button.openCertManager false security.warn_viewing_mixed false </code> I am making heavy use of soft links on my systems : ~/Library/* (temp, cache, preferences, etc) is spread onto several physical volumes, and the filetree is done with soft links. No applications has any problem, except Firefox.