Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

files downloading instead of opening in viewer

  • 2 svar
  • 0 har dette problem
  • 475 visninger
  • Seneste svar af Miami Sally

more options

I've spent many hours trying to fix this problem. When I click on a document that I want to view, it is downloading to my computer. I have the latest version of firefox on a windows 11 pc. Please assist.

I've spent many hours trying to fix this problem. When I click on a document that I want to view, it is downloading to my computer. I have the latest version of firefox on a windows 11 pc. Please assist.

Valgt løsning

Hi Sally, what kind of document is it? For example, a PDF, an Excel sheet, etc.


I apologize that the following is long, but I wanted to provide some more background and options for opening PDFs.

Using the Open in Firefox option

Firefox can't display PDFs without downloading and saving them somewhere. You can tweak some hidden settings to determine where Firefox saves the file, whether that is the web content cache, the "Save files to:" download folder, or the Windows Temp folder. Here are the slightly messy details.

Background: inline vs. attachment disposition

If web servers don't specify how Firefox should handle a PDF, or if they specify "inline" handling, then then Firefox loads the PDF as web content with its original URL in the address bar. The PDFs are saved with other cached web content, not in your download folder. This is good.

But web servers can try to force a download by setting Content-Disposition: attachment if they don't want browsers to show the files in a tab. Firefox changed what it does in this case:

Before Firefox 98: Firefox always showed a download dialog, even though you had already told Firefox what you wanted to do, even when you checked the box to always do this in the future. It was kind of infuriating.

Firefox 98+: Firefox downloads the file automatically and then opens it. Because these are saved to disk the URLs start with file:///. By default, they are saved in your "Save files to" folder on the Settings page.

New options for saving downloads

In response to user suggestions/complaints, Mozilla added some options to modify the above:

(1) Just for PDFs, override "attachment" disposition to "inline"

When your handling action is "Open in Firefox", all PDFs can now be opened as web content and saved in the cache instead of a regular folder. Here's how you set this up:

(a) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. I'm using this so I feel comfortable mentioning it.

(b) In the search box in the page, type or paste browser.download.open_pdf_attachments_inline and pause while the list is filtered -- requires Firefox 103 or later

(c) Double-click the preference to switch the value from false to true

(2) For all the downloads Firefox saves to disk and opens automatically, change from the "Save files to" folder to the Windows Temp folder (if you made the change in #1, this will affect other kinds of files rather than PDFs)

Here's how you access it:

(a) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(b) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered -- requires Firefox 102 or later

(c) Double-click the preference to switch the value from false to true

This would not affect files opened with inline disposition; those will still be in the web content cache.

Hopefully some of that gets Firefox working the way you want.

Læs dette svar i sammenhæng 👍 1

Alle svar (2)

more options

Valgt løsning

Hi Sally, what kind of document is it? For example, a PDF, an Excel sheet, etc.


I apologize that the following is long, but I wanted to provide some more background and options for opening PDFs.

Using the Open in Firefox option

Firefox can't display PDFs without downloading and saving them somewhere. You can tweak some hidden settings to determine where Firefox saves the file, whether that is the web content cache, the "Save files to:" download folder, or the Windows Temp folder. Here are the slightly messy details.

Background: inline vs. attachment disposition

If web servers don't specify how Firefox should handle a PDF, or if they specify "inline" handling, then then Firefox loads the PDF as web content with its original URL in the address bar. The PDFs are saved with other cached web content, not in your download folder. This is good.

But web servers can try to force a download by setting Content-Disposition: attachment if they don't want browsers to show the files in a tab. Firefox changed what it does in this case:

Before Firefox 98: Firefox always showed a download dialog, even though you had already told Firefox what you wanted to do, even when you checked the box to always do this in the future. It was kind of infuriating.

Firefox 98+: Firefox downloads the file automatically and then opens it. Because these are saved to disk the URLs start with file:///. By default, they are saved in your "Save files to" folder on the Settings page.

New options for saving downloads

In response to user suggestions/complaints, Mozilla added some options to modify the above:

(1) Just for PDFs, override "attachment" disposition to "inline"

When your handling action is "Open in Firefox", all PDFs can now be opened as web content and saved in the cache instead of a regular folder. Here's how you set this up:

(a) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. I'm using this so I feel comfortable mentioning it.

(b) In the search box in the page, type or paste browser.download.open_pdf_attachments_inline and pause while the list is filtered -- requires Firefox 103 or later

(c) Double-click the preference to switch the value from false to true

(2) For all the downloads Firefox saves to disk and opens automatically, change from the "Save files to" folder to the Windows Temp folder (if you made the change in #1, this will affect other kinds of files rather than PDFs)

Here's how you access it:

(a) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(b) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered -- requires Firefox 102 or later

(c) Double-click the preference to switch the value from false to true

This would not affect files opened with inline disposition; those will still be in the web content cache.

Hopefully some of that gets Firefox working the way you want.

more options

Thank you very much. Mostly pdf's are at issue. I hope this did it! I'm tired out from the problem and have to get back to work. Thanks, again.