Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Double-click Chinese text not to select a word but a whole sentence

  • 8 svar
  • 0 har dette problem
  • 73 visninger
  • Seneste svar af Jason

more options

Ctrl + left arrow similarly cannot differentiate between Chinese word boundary. Is there a way to recognize Chinese words like Google Chrome does?

Ctrl + left arrow similarly cannot differentiate between Chinese word boundary. Is there a way to recognize Chinese words like Google Chrome does?

Valgt løsning

This is fixed in Firefox 118 Beta, it currently requires going to about:config in the address bar and changing intl.icu4x.segmenter.enabled to true (Bug 1719535).

Læs dette svar i sammenhæng 👍 1

Alle svar (8)

more options

Ændret af Jason den

more options

Dropa 德罗帕 said

Again which is the Firefox language version? It's either Chinese Firefox or English Firefox Browser version.

I said, Chinese

more options

Not 100% clear, but I can triple click to get the first section in the red circle and holding CRTL + Shift + arrow key to select word by word. see screenshot

https://world.chinadaily.com.cn/a/202309/07/WS64f8ff86a310936092f20a1a.html

Ændret af jonzn4SUSE den

more options

Jason said

Dropa 德罗帕 said

Again which is the Firefox language version? It's either Chinese Firefox or English Firefox Browser version.

I said, Chinese

In the future it would move things along faster if you provide links and examples. It took me a minute to find something in Chinese.

Ændret af jonzn4SUSE den

more options

For example, in Chrome double-click will select “中国”(means “China”),but select “中国队先在半决赛中对阵东道主韩国队” in Firefox.

So what i want is select a Chinese word instead of a sentence.

Ændret af Jason den

more options

for example, in Chrome double-click will select “中国”(means “China”),but select “中国队先在半决赛中对阵东道主韩国队” in Firefox.

So what i want is select a Chinese word instead of a sentence.

more options

Valgt løsning

This is fixed in Firefox 118 Beta, it currently requires going to about:config in the address bar and changing intl.icu4x.segmenter.enabled to true (Bug 1719535).

more options

zeroknight said

This is fixed in Firefox 118 Beta, it currently requires going to about:config in the address bar and changing intl.icu4x.segmenter.enabled to true (Bug 1719535).

It's cool. Thank you very much