Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Move the close button to the left

  • 6 svar
  • 0 har dette problem
  • 10 visninger
  • Seneste svar af Ed

more options

I have been using these userChrome settings:

 https://support.mozilla.org/en-US/questions/1365405

and now with the latest release, the close button is back to the right. That Mozilla doesn't follow the OS environment norms is utterly baffling, or at least provide a Setting for close button position. Can anyone provide a solution please?

I have been using these userChrome settings: https://support.mozilla.org/en-US/questions/1365405 and now with the latest release, the close button is back to the right. That Mozilla doesn't follow the OS environment norms is utterly baffling, or at least provide a Setting for close button position. Can anyone provide a solution please?

Alle svar (6)

more options

That rule --

.tabbrowser-tab .tab-close-button {
  -moz-box-ordinal-group: 0 !important;
  margin-inline: -2px 2px !important;
}


-- still seems to be working for me on Windows. I can't test on Mac.

Is this the only rule in your userChrome.css file that stopped working? If Firefox seems to be ignoring the file, you may want to double-check this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste toolkit.legacyUserProfileCustomizations.stylesheets and pause while the list is filtered

(3) That preference needs to have a value of true. If it's set to false, double-click it or click the toggle button on the right side to switch the value from false to true

more options

I set this up in the release of Firefox (111.0) and it worked. The problem is Firefox Nightly (113.0a1).

more options

rob196 said

I set this up in the release of Firefox (111.0) and it worked. The problem is Firefox Nightly (113.0a1).

Change

-moz-box-ordinal-group: 0 

to order: 0

From https://www.reddit.com/r/FirefoxCSS/comments/11odffm/psa_incoming_changes_to_default_element.

more options

rob196 said

I set this up in the release of Firefox (111.0) and it worked. The problem is Firefox Nightly (113.0a1).

Change -moz-box-ordinal-group to order

order: 0 !important;

more options

You may have to use order:-1 and possibly add the !important flag.

  • -moz-box-ordinal-group: 0 ==> order: -1
more options

cor-el said

You may have to use order:-1 and possibly add the !important flag.
  • -moz-box-ordinal-group: 0 ==> order: -1

Right, it needs to be -1 with !important;