Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox informs me that my browser is being managed by my organization.

  • 8 svar
  • 2 har dette problem
  • 16 visninger
  • Seneste svar af jonzn4SUSE

more options

As I belong to no organization, I find this disturbing. Some of the settings being "managed" for me are not as I want them. How do I get access to them? FWIW. I am using Firefox in Linux Mint. Thank you for your help.

As I belong to no organization, I find this disturbing. Some of the settings being "managed" for me are not as I want them. How do I get access to them? FWIW. I am using Firefox in Linux Mint. Thank you for your help.

Alle svar (8)

more options

Take a look at this similar issue. https://blog.linuxmint.com/?p=4244

https://support.mozilla.org/en-US/kb/see-active-policies-firefox-enterprise

https://github.com/mozilla/policy-templates/blob/master/README.md On Linux, the file (policies.json) goes into firefox/distribution, where firefox is the installation directory for firefox, which varies by distribution or you can specify system-wide policy by placing the file in /etc/firefox/policies.

Ændret af jonzn4SUSE den

more options

The Linux tarballs from www.mozilla.org/firefox/all has updates from Mozilla as long as the Firefox folder has read/write permissions for the user. A easy way is to have Firefox folder in Home.

The Firefox packages from Mint are updated by them and not Mozilla.

more options

jon: What I got from the link was that under Linux group policies can be set only with policies.json. Unfortunately, that file contains only one item. It shuts off autoupdate. What am I missing?

James: Unfortunately, I am a total newbie at Linux and at fiddling with software at this level in general. I know what a tarball is, but I don't know what to do with it in this situation. Can you instruct me?

Many thanks to you both for trying to help.

Owen

more options

That file is the reason you are getting the message that your browser is being managed by your organization.

more options

Terry said

That file is the reason you are getting the message that your browser is being managed by your organization.

Not by any organization. In Linux Mint the Update Manager is responsible for all software updates for the package builds.

more options

owen58191 said

jon: What I got from the link was that under Linux group policies can be set only with policies.json. Unfortunately, that file contains only one item. It shuts off autoupdate. What am I missing? Owen

As was stated before, your distro handles updates like my distro version on openSUSE which is why I run both. see screenshot I suggest you just run both so that your data is not in just one browser. You can use sync to get your data in the Mozilla version of Firefox. There really is no issue here, just that mint handles updates for the distro version. I think they need to change the language used in the message.

more options

On their site, they also mention the need to change the verbiage.

In Linux Mint the Update Manager is responsible for all software updates, and applying updates requires root privileges.

“Your browser is being managed by your organization” might look a bit scary but all it means is that Firefox was told to not worry about updating itself.

In the About dialog, “Updates disabled by your system administrator” has the same meaning.

We’ll work with Mozilla on this, first to rephrase this, and hopefully later this year to be able to handle Firefox updates from within Firefox.

more options

If you're feeling adventurous, rename the file to policies.json_old, restart Firefox and see if you can manually update it.