Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wrong flavicon appearing in tool bar

  • 7 svar
  • 0 har dette problem
  • 1 visning
  • Seneste svar af dans500

more options

I'm using the latest Firefox browser on my PC running Windows 10.

Suddenly the Flavicon for my web site (indymotorspeedway.com) is displaying Yahoo!'s flavicon in the tool bar. Other flavicons in tool bar are ok. When I open my web site in a tab, the correct flavicon appears in the tab. (see attached photo)

This problem occurred at the same time as another problem - My browser began displaying at a much larger size. Using <ctrl> + mouse scroll button, 80% is the size I'm used to seeing.

I checked that my Display settings in Windows had not changed.

[What may have started these problems: I don't use other browsers, but have them (Avast, Chrome, IE, Edge, Vivaldi) installed in case I need to test something. I started all of them to test a web site, before these problems began. If I recall, at some point I accidentally clicked by some box, which may have been changing my preferred search engine to Bing.]

I went to Firefox settings. I had to reset Firefox as the default browser. I can't remember if I had to change the default search engine back to DuckDuckGo.

I switched the zoom size from 100% to 80% and back several times. For now, the browser is back to displaying at its normal size.

Note: The correct flavicon is appearing in the tool bars of Chrome and Edge.

I'm using the latest Firefox browser on my PC running Windows 10. Suddenly the Flavicon for my web site (indymotorspeedway.com) is displaying Yahoo!'s flavicon in the tool bar. Other flavicons in tool bar are ok. When I open my web site in a tab, the correct flavicon appears in the tab. (see attached photo) This problem occurred at the same time as another problem - My browser began displaying at a much larger size. Using <ctrl> + mouse scroll button, 80% is the size I'm used to seeing. I checked that my Display settings in Windows had not changed. [What may have started these problems: I don't use other browsers, but have them (Avast, Chrome, IE, Edge, Vivaldi) installed in case I need to test something. I started all of them to test a web site, before these problems began. If I recall, at some point I accidentally clicked by some box, which may have been changing my preferred search engine to Bing.] I went to Firefox settings. I had to reset Firefox as the default browser. I can't remember if I had to change the default search engine back to DuckDuckGo. I switched the zoom size from 100% to 80% and back several times. For now, the browser is back to displaying at its normal size. Note: The correct flavicon is appearing in the tool bars of Chrome and Edge.
Vedhæftede skærmbilleder

Ændret af dans500 den

Alle svar (7)

more options

Good afternoon!

I expect that your issue is simply that Firefox has cached the Yahoo! favicon which was there by default when you first set up your website (since it is hosted by Yahoo! currently).

Could you try clearing Firefox's history and cache to see if that resolves your problem?

more options

The web site is 25 years old and I've used Firefox for years. This problem just appeared.

As you suggested, I tried deleting all history, cache and data numerous times and also deleting the bookmark from the tool bar. I shut down and restarted Firefox numerous times too. I went to my web site and then saved the bookmark in the tool bar. The same problem.

I just went to a bookmark folder in Firefox where I keep numerous links to various areas of my web site. Every single one of them has the Yahoo! flavicon.

more options

I just realized that web pages are displaying at their normal size - BUT it's my web site that is displaying way too big! Nothing has changed with my site and it appears normal on other browsers.

I feel confident the problem is with my Firefox.

I wonder if something has gone wrong on my version or whether this is a new problem from a recent Firefox update. Will anyone go to my site via a Windows 10 PC using Firefox and bookmark it, then see what the flavicon is please?

more options

I went to the site and both my tab and bookmark has a Indy 500 looking icon. Looking at the page info, it is loading this icon: http://indymotorspeedway.com/favicon_new.ico

I suppose you can also make a copy of that icon in the root directory and call it favicon.ico as the default icon if a browser doesn't look at the <link rel="shortcut icon" href="/favicon_new.ico"> line.

Might try viewing the icon directly and if it doesn't show correctly, do a CTRL-F5.

I am using Firefox 103 in Windows 10 Pro.

more options

To see whether it is a problem with settings, add-ons, or accumulated data in your current Firefox setup, you could try:

New Profile Test

This takes about 3 minutes, plus the time to test your site.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Test2022, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Test2022 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Does the text/zoom on your site look any better in the new profile? Does bookmarking work as expected?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Test2022 will remain available for future testing.)

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.


This could be a problem with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

more options

Thank you for your help JSCHER200

When i created a new profile, the flavicon problem disappeared.... for a short time.

I decided to start using this new profile, so the first thing I did was export and import my bookmarks (approx 3,500 links.) and the problem came back! I tried deleting all of the new bookmarks, but that didn't help.

I created another new profile and tried again, this time importing the bookmarks to the Bookmarks Toolbar folder. A link to my web site in the main directory showed the Yahoo! flavicon. I deleted it. I then noticed that the flavicons for most of my bookmarks had been replaced with a globe like icon - see attached photo. Weird. This problem is more annoying than the original problem! The original problem with the flavicon in the bookmark tool bar has not returned on this 3rd profile.

It seems to me there is something strange going on with Firefox's bookmark system. It could be they've made some changes and didn't consider bookmark lists as large as mine. Or, it could be something has just gone buggy with my Firefox and I'll need to uninstall it. If you have further ideas, feel free to share.

NOTE: I've found the sizing problem is happening on all my browsers, so please disregard. (my 1020-pixel-wide site is showing up 1330-pixel-wide)

Thanks!