Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Denne tråd blev lukket og arkiveret. Stil et nyt spørgsmål, hvis du har brug for hjælp.

FF 94.0.1 on Mac shuts fullscreen mode on esc

  • 6 svar
  • 3 har dette problem
  • 88 visninger
  • Seneste svar af jdh212

more options

One of the latest FF updates broke my workflow. (https://xkcd.com/1172/) I'm using the browser in full-screen mode all the time (13" doesn't provide that much of vertical space), and now it shots down every time I tap ESC — which, as you may imagine, I do a lot. Don't like being that guy, but this _really_ breaks the flow. Could you tell, is it 1) intentional change; 2) and configurable behavior. What can I do to revert this particular thing?

One of the latest FF updates broke my workflow. (https://xkcd.com/1172/) I'm using the browser in full-screen mode all the time (13" doesn't provide that much of vertical space), and now it shots down every time I tap ESC — which, as you may imagine, I do a lot. Don't like being that guy, but this _really_ breaks the flow. Could you tell, is it 1) intentional change; 2) and configurable behavior. What can I do to revert this particular thing?

Valgt løsning

Ok, the real answer for my q is: "Switch browser.fullscreen.exit_on_escape in about:config to `false`"

Læs dette svar i sammenhæng 👍 3

Alle svar (6)

more options

It is intentional that pressing the ESC key makes you leave Full Screen Mode.

What reasons/issues do you have that makes you press ESC so often ?

more options

Well, closing any popups on websites & search panels and stuff. Generally, on previous versions ESC hadn't been disrupting fullscreen (in, like, 3+ years I'm using FF as my daily driver), so can't tell whether this change is for good — I don't have or want access to your product metrics and such — but it's kinda a deal-breaker for me. Having to be mindful of whether the focus is on any particular site element doesn't sound like a good thing to spend small bits of attention I still do wield.

Anyway, I suppose your question-instead-of-answer means there's no way to switch this off, so the options I do have are 1) building my own extension catching keydowns or something on window-level; 2) switching to, I don't know, Chrome. Both are, to say the least, sub-optimal, and that's why I asked on whether that was an intentional change.

more options

Valgt løsning

Ok, the real answer for my q is: "Switch browser.fullscreen.exit_on_escape in about:config to `false`"

more options

I wasn't aware that this browser.fullscreen.exit_on_escape pref exists. Leaving full screen mode via ESC appears to be a Mac feature added in 92 (1688584) and was disabled for 93 by adding the browser.fullscreen.exit_on_escape pref (1726810;false) and got enabled again in 94 (1732367;true).

more options

A very annoying change of defaults. Thank you for the solution, this made Firefox almost unusable.

more options

I just created an account for the first time to vote up the solution and vote down @cor-el's response.

This the thread is the first result I got when searching for a solution to the problem I was having with MacOS fullscreen mode and escape-key behavior changes.

Thank you @kadmil for asking and answering this question, the behavior change was very annoying and unexpected.

I returned to Firefox from Chrome and have been very happy, up until this behavior change ruined my constant use of fullscreen mode on a tiny macbook air 11.

This is a legitimate issue and question, asked honestly and well, with a bit of humor. It deserved a better community response.

Poor moderator responses like this give Firefox a bad name. Please do better.

Ændret af jdh212 den