Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

calendar invitations are not sent since upgrade to 91

  • 17 svar
  • 5 har dette problem
  • 178 visninger
  • Seneste svar af fmalan

more options

I upgraded to version 91 a while ago and the calendar invitations are not being set to me or the other invitees. I am currently at version 91.2.1 but this is the first calendar item with attendees. This has worked for years. I am on windows 10. I use the local Thunderbird calendar.

I upgraded to version 91 a while ago and the calendar invitations are not being set to me or the other invitees. I am currently at version 91.2.1 but this is the first calendar item with attendees. This has worked for years. I am on windows 10. I use the local Thunderbird calendar.

Ændret af vsmith42 den

Valgt løsning

I am now up to 91.7.0 32 bit version. Some time ago the send notifications just started working. Sorry I did not notify you when that happened. I made no changes to account for it so I assume it was one of the updates.

Læs dette svar i sammenhæng 👍 0

Alle svar (17)

more options

Right-click the calendar in the left pane of the Calendar tab, Properties. Is there an Email account defined?

more options

Yes there is an email address defined. It is that same email I used previously and got the invitations sent before the upgrade. I have checked and I can send and receive using that email address.

more options

When you click Invite Attendees in the New Event window, does that (your) email address appear as the first one on the left side, and do other invitees autocomplete when you start typing their name (see picture)?

more options

Yes, When I click "Invite Attendees", the popup window looks like your picture. My email address is already there. When I start typing in the next attendees name, it is auto completed. If the name I type has multiple possibilities, it gives me a list to click the one I want. After I click "OK", I have "Notify attendees" checked and the email addresses of the organizer and attendees are correct. I have tried having "Separate invitation per attendee" checked and non-checked. Then I click "Send and Close" but no emails are sent. If I then edit the event and change the date and click "Send and Close", I still get no emails. Thanks.

more options

I did a test on a local calendar with invitations sent to 2 attendees, and the messages were sent. I can't say why yours doesn't work. Is there any difference in safe/troubleshoot mode (hold Shift when launching TB)?

more options

I tried safe mode with out disabling plugins and then with the plugins disabled and still no emails.

more options

Was this a calendar that was upgraded from 78? Many users have had issues with the calendar disappearing after the update. Try creating a new local calendar, define the Email account, add an event with invited attendees, and see if the invitations are sent.

more options

This calendar was an upgrade from a previous version, what ever version came before 91. I created an new local calendar and added an event with attendees but still no emails were sent. I even tried it in safe mode but no invitations sent.

more options

I notice that the invitations are sent, but an error message appears about not being able to save the sent message to the IMAP Sent folder. Check that they aren't in fact received by the recipient, and perhaps view the Error Console, Ctrl+Shift+J, after sending in case it indicates the reasons for not sending.

more options

The emails are not being sent. One attendee is my yahoo email address which I access with TB as well as the email of the organizer. The attendee does not get the email and there is not sent email. I checked the Error console and I see no messages related to the invitation. I ran this test using the original local calendar and the newly created local calendar and get the same result. I was thinking of uninstalling TB and reinstalling it. I am afraid that the calendar history will be lost. Is it possible to export it, reinstall and then import it?

more options

A reinstall doesn't affect the user data in the separate profile folder, and it usually doesn't help if problem is due to a flaw in the profile. But there are Export and Import options under the Events & Tasks menu.

A better option is to create a new profile from Help/More Troubleshooting, about:profiles, add a mail account, create a new local calendar linked to that account, and see if invitations work properly. My tests were made with a profile created with 91, not one previously used in 78.

more options

Hello, I'm at the same situation. Since I've updated to version 9.2.1 the invitation email can't be sent to atendees. My colegue have the same issue. Should I wait for the next release or it is possible to fix it?

Ændret af boyan.boyadjiev den

more options

Any update on this? When I hit "Send and Close" it doesn't actually send the invites... I can tell because it's not in my Sent folder whereas it used to be. I checked Properties in Lightning and my email is still linked to the calendar.

When I test and send an invite from another email account (as an organizer) to the email account linked in Thunderbird/Lightning (invitee): if I decline the invite it will send a response to the organizer, but if I accept the invite then it won't send a response to the organizer. I'm guessing because "accept" is processed through Lightning since the event is added to the calendar first before a response is sent, but when I decline it it doesn't go through Lightning? Please help....

Ændret af hwngthms den

more options
more options

I have the same problem on 91.7.0 (64 bit) but not on 91.7.0 (32 bit). The 32/64 bit is probably a red herring since the users are different on the two different machines: the problem is most probably due to the profile data. On the offending installation where the invites are not sent (and are not recorded in the Sent folder) the Error Console after Save and Close has been pressed contains:

[Exception... "[JavaScript Error: "newelement.setOccurrence is not a function" {file: "chrome://calendar/content/agenda-listbox-utils.js" line: 299}]'[JavaScript Error: "newelement.setOccurrence is not a function" {file: "chrome://calendar/content/agenda-listbox-utils.js" line: 299}]' when calling method: [calIObserver::onAddItem]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: resource:///modules/calendar/utils/calDataUtils.jsm :: notify :: line 38" data: yes]

I do not know JavaScript, but this looks suspiciously like something in the code causing a JS error which then terminates the code execution before sending the email notification. The "something" is most probably data-driven, i.e. something in the profile. But what?

more options

Valgt løsning

I am now up to 91.7.0 32 bit version. Some time ago the send notifications just started working. Sorry I did not notify you when that happened. I made no changes to account for it so I assume it was one of the updates.

more options

I ended up doing a clean re-install of Thunderbird (this time via Ubuntu snap), and this solved my problem. Still no idea why it occurred in the first place. Transferring the entire profile directory's content from the old to the new thunderbird also preserved the problem, so I had to set up my account anew and copy parts of the profile containing my achived mail folders.