Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error NS_ERROR_NET_INADEQUATE_SECURITY on every page

  • 6 svar
  • 1 har dette problem
  • 25 visninger
  • Seneste svar af firefox1486

more options

Hi, I've been having issues with Firefox for some time now. Every page I got to throws a NS_ERROR_NET_INADEQUATE_SECURITY error. I cannot fix it by setting network.http.spdy.enabled.http2 to false is because Firefox then starts crashing. In the past I've gone around the error by turning http2 off, but recently, first the developer edition, then after today's update to 91.0-0.1 of stable version Firefox crashes if I turn the feature off.

The developer Edition started throwing NS_ERROR_NET_INADEQUATE_SECURITY sometime in spring, then started crashing in June I think. The stable version followed soon as described above.

I am submitting this ticket from a beta version, which for some reason does not have this issue.

I thought it may be the Linux version of Eset, but removing it did not help. I cannot think of any other reason why am I getting those errors, but it seems I am alone because my colleagues don't seem to have this issue neither on macOS, nor Windows.

Alle svar (6)

more options

foutcode NS-ERROR-NET-INADEQUATE-SECURITY

NS_ERROR_NET_INADEQUATE_SECURITY indicates that the server initiates a HTTP/2 connection, but Firefox detects an invalid TLS configuration in the server response (server negotiated HTTP/2 with blacklisted cipher suites). This is likely not an issue with the certificate, but this is a problem with the server setup and there are invalid cipher suites for HTTP/2 claimed (INADEQUATE_SECURITY).

http://httpwg.org/specs/rfc7540.html#TLSUsage There might also be other software that acts as a MITM and is interfering. When HTTP/2 is enabled and used then the requirements are much stricter than with HTTP/1.1 You can get the NS_ERROR_NET_INADEQUATE_SECURITY error message in case the server isn't configured properly.

A workaround to fix this ANNOYING issue is; network.http.spdy.enabled.http2 = false in about:config

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Nyttig?

more options

As I already said, I cannot set network.http.spdy.enabled.http2 = false because Firefox starts crashing

Nyttig?

more options

Can you try a separate copy of Firefox? Just download to a folder and run it to see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Ændret af jonzn4SUSE den

Nyttig?

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?


Is the Firefox 91.0 version also from the Mozilla server like the 92 beta or from the Linux repositories ?

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Nyttig?

more options

The FF version is from Arch repository

Try the Firefox version from the official Mozilla server

I wasn't getting the error when running FF downloaded from Mozzila's site.

You can create a new profile as a quick test to see if your current profile is causing the problem.

Creating a new profile did not solve it, I still encountered NS_ERROR_NET_INADEQUATE_SECURITY

As a sidenote: Is it possible that custom theme that I had used before the new UI overhaul could cause this issue?

Ændret af Polygon Unicorn den

Nyttig?

more options

downloaded 92.0 in other folder but same problem https://www.mozilla.org/ -> NS_ERROR_NET_INADEQUATE_SECURITY put network.http.spdy.enabled.http2 -> false continue crashing whith no activity or when typing address site without http2 works ok

dump telemetry 4e36860d-388e-9d89-7dc7-3b47d2c27352

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.