Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox uses generic font instead th font that is used in websites

  • 2 svar
  • 1 har dette problem
  • 25 visninger
  • Seneste svar af alfa8link

more options

First of all excuse my English because it's not perfect. The problem came with the new version 90.0.1. There are some websites I visit every day, and after installing new version of FF I noticed that the fonts used in websites are different than it was before. Some websites are breaking apart and doesn't look like they did before, and like they look in other major browsers right now.

Examples: http://www.alterego.co.rs/_knjigovodstvo/aktuelno.html https://www.arrowheadpride.com/

I went to the Settings option and saw that my FF is set to show Times New Roman 16 as default font, but if I go to Advanced I can see that the checkbox on Allow pages to choose their own fonts, instead of your selections above option is ON. So websites should be shown not by default font, but the font used in websites. But if I turn that option OFF, than I can see websites like it should be, like it was before new version, and like it's shown in other major browsers. But it gives me wrong look (font) with some other websites, so it's not the permanent solution. I guess it's some kind of problem with new version of FF.

Note: Same thing happend a couple of weeks or months ago with one of previous FF versions, but that was fixed just day or two later with another new version. It looks like we have simmilar problem right now.

Thanx in advance for any help, and I hope somebody will fix that soon. I am lifelong user of FF browser because it's my favourite and the best, but that kind of problem can be pretty big for someone who is very often online and who is working in developing websites sometimes.

Thanx again Dragan

Alle svar (2)

more options

Hi Dragan, I have a guess based on your experience with Firefox 89. Could you test:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.e10s.font-list.shared and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I suspect that won't take effect until the next time you quit and restart Firefox.

Any improvement?

Background

This preference controls whether Firefox saves memory in individual content processes by using a shared fonts list. It was first enabled in Firefox 89.0, but was quickly disabled in 89.0.1 due to some crashes. After the crash bugs were fixed, this feature was re-enabled in Firefox 90.0.

If you have some time, could you file a bug report with screenshots of the problem? I think the developers will need more input to get to the bottom of it. https://bugzilla.mozilla.org/

Nyttig?

more options

Dear jscher2000

Your suggestion DID solve the problem. Now websites really show the font that is used originally by them. Thank you very much, but I guess that nothing is really solved before new version fix that for all of us. Hope it will be done soon.

Thank you again, and if you need more feedback from me, I'll be very happy to contribute if I can. Right now I am at work, but later I can do whatever you need me to do (you can tell me how to file a bug report and where, if you need me to do).

All the best to you and everyone at FF comunity!!

Dragan

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.