Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Light theme text in sidebar, is white on white (and is the sidebar theme for all installed themes)

  • 8 svar
  • 1 har dette problem
  • 5 visninger
  • Seneste svar af kimcosmos

more options

Default Light theme has white text in the sidebar (on white background). All added themes use the default theme in the sidebar. How do I fix the sidebar light theme? Safe mode (all extensions disabled) has exactly the same light theme sidebar problem

Vedhæftede skærmbilleder

Alle svar (8)

more options

Changed default theme to dark in dev settings. Didn't help. The sidebar is stuck in the white on white for all themes except alpenglow and dark. And yes some of my themes change the text color (but not in the sidebar) and yes its the same problem with all extensions and themes disabled. Same problem with all about.config sidebar and theme settings returned to defaults. And why can't I edit my own questions before there are replies and before I log out?

Nyttig?

more options

ie this is a sidebar light theme, text color setting problem. Most themes use white background with photos and change the bar text colors but not the sidebar text color. Mozilla themes change the background color and all text color but the sidebar text in FF light theme and installed themes is not going black, unlike in the tabs etc.

Nyttig?

more options

1. the built in themes all have white text in the sidebar (even the light one). 2. All installed themes have a white background in the sidebar, making it unusable. 3. the default theme (now dark) does not touch the sidebar white on white.

Nyttig?

more options

I have black text on a white background when I use the default, light and my chosen themes. I have the following setting marked 'false'; I forget what that signifies but you might try 'true' which seems to be the default. You may need to create the setting. browser.in-content.dark-mode (This site has attempted to convert that to a link, ignore that.) I have a Linux OS and the distro does NOT change the Mozilla product.

Ændret af TerryN21 den

Nyttig?

more options

Thanks but about:config has no in-content or dark-mode Where is that setting? I added browser.in-content.dark-mode as boolean but neither true nor false has any effect

Nyttig?

more options

Interesting that the setting is not there at all. Set that to true and restarted and it did not help. It might be because I am using FF88.0.1 (64 bit) Manjaro 1.0 version. Seems the Manjaro version is quite different. No 'in-content'. Configs 'dark' search only has widget.content.allow-gtk-dark-theme false widget.disable-dark-scrollbar false

Nyttig?

more options

The setting has been referred to in a number of questions on this site; this is the latest I see in my web search: https://support.mozilla.org/questions/1279034 The setting may have vanished, the way things do; there is a 'bin' icon alongside the setting in my about:config (sorry, I should have said about:config). If you get no joy here, you could consider using userChrome.css to change the colours in the sidebar. The reddit Firefox/CSS sub may help. https://www.userchrome.org/how-create-userchrome-css.html


[Locale removed from support link by moderator.]

Ændret af Chris Ilias den

Nyttig?

more options

the bin icon means it is a removable setting. Presumably added. I also noticed that the dark reader extension only works intermittently too. Not on this site for example despite adding this site. This problem occurs with browser.in-content.dark-mode 'true' in restarted safe mode - as I said. I will try chrome css. Changing the sidebar theme only is a bit of a kludge anyway

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.