Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Mozilla Authentication Required"

  • 14 svar
  • 1 har dette problem
  • 21 visninger
  • Seneste svar af cor-el

more options

attempting to open THIS normally openly-accessible public site:


I find this returned:

"Mozilla - Authentication Request.

"https:// (etc.)" is requesting your username and password. 
 The site says: “TT Internal”
User Name: _______________________ 
Password:   _______________________ "*
 (*cannot "screen-shoot" this page)

I use Windows 10 and the latest available Mozilla Firefox 88 browser.

 Thanks for your reply/(ies)
Vedhæftede skærmbilleder

Ændret af gbrusse88 den

Alle svar (14)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Please see revised Question above.

more options

By the looks of it your service is requesting your user name and password and this would occur no matter what Web Browser you use or OS you are using. If no other Web Browser is requesting this you may have already logged in and it is remembering your information (via cookies or such).

more options

I wish it were (seemingly) that simple. If you're right, what would be the solution ? However, the site in question, though it has been a while since I tried to access it, has never required any login to access its routine files as they are supposedly open and freely available to the general public without registration or login. There is no notice (at any prior point) that this has changed in the meantime. Otherwise, one should expect a "login required" notice somewhere--but I see no such thing.

And I've changed nothing about my own system's settings which does, has or ought to explain such an inability to access any otherwise open and accessible site. E.g. there aren't any other sites which I've routinely accessed but now cannot because of some change I've made to the settings on my system or its internet access through the browser.

I'm still blocked and still stumped as to why and how.

more options

What is the name of the website for a web search?

more options
more options

Hmm, are you user the server is set up for HTTPS? When I look at results in Google, they are on HTTP:


more options

RE: jscher2000 Top 10 Contributor 5/10/21, 1:21 PM "Hmm, are you user the server is set up for HTTPS? When I look at results in Google, they are on HTTP"

 Makes no difference to my ability to access the site.  I get the same block whether I try "http" or "https".
more options

FredMcD Top 10 Contributor 5/10/21, 1:03 PM https://downforeveryoneorjustme.com/shakespeare.mit.edu?proto=https

Shakespeare.mit.edu Status Is shakespeare.mit.edu down right now?

It's not just you! shakespeare.mit.edu is down.


Thanks, I tried the site you linked and got the "site is down" message, too. And I still get that returned. Likewise for you? Any suggestions for contacting them and confirming directly with MIT.edu's administrators?

more options

I recently received this, in reply, from "MIT.edu" : "The website http://shakespeare.mit.edu is working for me, and it’s not password protected."

       (@ around 14:52 Hrs. 11 May 2021)
more options

gbrusse88 said

RE: jscher2000 Top 10 Contributor 5/10/21, 1:21 PM "Hmm, are you user the server is set up for HTTPS? When I look at results in Google, they are on HTTP" Makes no difference to my ability to access the site. I get the same block whether I try "http" or "https".

I don't get the message for links in Google results.

If your Firefox is forcing the addresses to HTTPS, this could be caused by Firefox's HTTPS Only feature (see HTTPS-Only Mode in Firefox) or by an add-on such as HTTPS Everywhere.

more options

J.S. : I specifically just ensured that, in the settings in Firefox, the "https only" option was not in effect--and then re-tried the URL.

No difference. No change.

more options

Is the address bar changing from http to https or are you getting the error without any redirect?

If there is a redirect to https, there are several possible reasons. We have reviewed some of them, but you also could clear Firefox's web cache and/or test in a private window.

How to clear the Firefox cache (only check the box for web cache, don't clear all site data)

more options

If you access the website via https:// the you get dialog to enter login credentials, so you need to access the website via http://.

If you use HTTPS-Only mode then you can use this code in the Browser Console (not the Web Console) to create an exception. The code works as a toggle, but you should be able to remove the exception via the padlock.

See this article on how to enable the command line in the console.

const HTTPS_ONLY_PERMISSION = "https-only-load-insecure";
var uri = gBrowser.selectedTab.linkedBrowser.currentURI.spec;
if (uri && /^https?:/.test(uri)) {
 uri = uri.replace(/^https:/,'http:');
 if (Services.perms.testPermissionFromPrincipal(Services.scriptSecurityManager.createContentPrincipalFromOrigin(uri), HTTPS_ONLY_PERMISSION)) {
 Services.perms.removeFromPrincipal(Services.scriptSecurityManager.createContentPrincipalFromOrigin(uri), HTTPS_ONLY_PERMISSION);
 console.log('Removed: HTTPS_ONLY_PERMISSION', uri);
 } else {
 console.log('Added: HTTPS_ONLY_PERMISSION', uri);
} else {console.log('invalid URI')}
} catch(e){}