Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When opening Firefox, it closes immediately

more options

Hi!

My system:

  • Win 10 64 Bit Desktop, completely up-to-date
  • Two windows user accounts: one admin account and one standard user account
  • using Windows defender / firewall only (NO third party virus scanner / firewall)
  • Firefox 87.0

The last day, Firefox worked without noticeable problems. Nothing special happened. However, on the next morning, the problems appeared all of a sudden on the windows standard user account (The windows admin account is NOT affected by the problem):

When clicking the Firefox icon, the Firefox window appears for a split second and then disappears. In Task Manager one can see the firefox.exe processes appearing and disappearing again. It seems that firefox closes itself or is closed by anything else right after startup.

There is no crash, no error message, no crash report. It is simply impossible to start firefox.exe, no matter in which way I try it:

  1. Same problem when trying to start in private window mode or in safe mode.
  2. Same problem when trying to start profile manager.
  3. Same problem when trying to start firefox.exe from windows explorer.

I already tried all the standard solutions, but nothing helped:

  1. Uninstall 64-Bit Firefox and reinstalled 64-Bit Firefox
  2. Uninstall 64-Bit Firefox and reinstalled 32-Bit Firefox
  3. I deleted all mozilla folders in all subfolders of %User%\AppData and also cleared any temporary files there (this should delete all user profile data and all extensions)
  4. I did a complete virus/malware scan using ten different malware/virus scanners (MalwareBytes, Adwcleaner, TDSSKiller, MSERT, Sophos, F-Secure, Kaspersky, Bitdefender, Windows Defender, ESET), some of them started from external boot media (i.e. they worked without the need to start Windows). Nothing has been detected.
  5. Disabling Windows Defender and Firewall as far as possible (meanwhile, I installed Bitdefender, so Windows Defender / Firewall are replaced)

I did a closer look using ProcessMonitor64, but I could not figure out any abnormalities (maybe you can give me hint what to look for?)

What I discovered:

  1. Renaming firefox.exe to anything else (e.g. firefox1.exe) makes it work (but this is not a solution of the problem because Firefox updates will no longer work then)
  2. The user of that PC starts Firefox by double clicking on the task bar icon. Usually, a simple click is sufficient. Could the problem be caused by a too slow double click (= interpreted as two single clicks) and a concurring start of two Firefox instances?

Any ideas?

Ændret af Tilack den

Valgt løsning

~dbben, with your ideas, I could trace back the problem a step further.

(Note: my Windows is in german, I hope my english translations of the german terms are correct.)

When entering "msconfig" in the search box, go to "Dienste" (Services) and disable "Jugendschutz" (Youth Protection). Then everything works fine again.

Is there a known conflict between Firefox and Windows' youth protection service? I have no idea where one can adjust the youth protection settings. I can only access the Safe Search Settings in the Windows Settings. I tried lowering from strict to medium, but this does not help.

By the way, I discovered that the problem also affects Opera GX while it does NOT affect Edge. (Honi soit qui mal y pense ...)

Additional note: Because the Youth Protection service may take some time for startup, when starting Firefox immediately right after login, it may show up its window properly at first glance. As soon, as Youth Protection is running, it shuts down Firefox. In these cases it seems as if a running Firefox closes all of a sudden.

Læs dette svar i sammenhæng 👍 0

Alle svar (5)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Nyttig?

more options

The Firefox version was unmodified; there was NO update; so "but no longer recognizes your updated version as trusted" does not apply.

As said,

  • All Windows components are up-to-date
  • I disabled Windows Defender / Firewall as far as possible and it did not help.
  • I meanwhile completely replaced Windows Defender / Firewall by Bitdefender (which comes with its own, plain rule set) and it did not help.
  • The problem only affects the windows standard user account. On the windows admin user account, there has never been any problem like this. (Windows Defender / Firewall uses the same set of rules for all windows user accounts, as far as I know; at least the fresh installed BitDefender does so.)

Nyttig?

more options

hello ti,

i assume that other browsers on your system are not effected by malfunction?

one of the initial things that i would do is to ensure there is no issue resulting from a lack of resources, like memory and space.

what i suggest to open the windows start up manager and disable "everything" that is starting up with the desktop. if you have a mouse driver and graphics driver, leave these alone.

also, double check the pagefile / virtual memory size and ensure the size recommendations cited in the pagefile window are being invoked.

also, create a c:\temp folder and then change the variables of the environment and system paths for the temp folder to c:\temp

then reboot and see how FF behaves.

if still no good, i think we can continue the process of elimination.

Nyttig?

more options

Valgt løsning

~dbben, with your ideas, I could trace back the problem a step further.

(Note: my Windows is in german, I hope my english translations of the german terms are correct.)

When entering "msconfig" in the search box, go to "Dienste" (Services) and disable "Jugendschutz" (Youth Protection). Then everything works fine again.

Is there a known conflict between Firefox and Windows' youth protection service? I have no idea where one can adjust the youth protection settings. I can only access the Safe Search Settings in the Windows Settings. I tried lowering from strict to medium, but this does not help.

By the way, I discovered that the problem also affects Opera GX while it does NOT affect Edge. (Honi soit qui mal y pense ...)

Additional note: Because the Youth Protection service may take some time for startup, when starting Firefox immediately right after login, it may show up its window properly at first glance. As soon, as Youth Protection is running, it shuts down Firefox. In these cases it seems as if a running Firefox closes all of a sudden.

Ændret af Tilack den

Nyttig?

more options

hello ti,

Thank you for updating us with your findings.

While I am not familiar with "youth protection", I believe that it is an application that protects "youths" from the dangers of the internet.

It might be like Google's safe search option, whereas google search results wont produce pornographic images or images that are emotionally horrible.

I believe window 10 also has a built-in mechanism that is used by parents to protect their kids while using the computer.

However, since i dont have kids and have no issues with seeing nasty pictures, I dont know how this feature to protect kids works.  :-)

I hope the above enlightens you a bit more on what likely was occurring with your system.

While we do not always have all the answers, we are hear to help as much as we can. And ultimately, the FireFox programming teams will read threads like yours here and gain a better understanding of what is going on.

Again, thanks for sharing !!

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.