Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What Happened to "Print Preview"?

  • 41 svar
  • 9 har dette problem
  • 545 visninger
  • Seneste svar af sjpalubinski

more options

A recent Firefox update has totally disrupted our ability to print from browser windows. There used to be a "Print Preview" button that allowed us to set things up the way we wanted them. That's now missing. As a result, stuff that used to cost us for ten pages now costs us for twenty pages. Also, when we print double-sided, the second side prints upside down.

This strikes me and my wife as a horrible development, and we would like to go back to the old version ASAP!

Valgt løsning

Hi Anan, Firefox 85 has a new print experience where the preview is integrated with the settings panel. It should appear if you choose Print from the menu or press Ctrl+P. Do you not get the overlay? What happens?

The double-sided printing problem -- short edge binding instead of long edge binding -- was a bug in Firefox 85 that should be fixed in Firefox 86 (according to this reply). Firefox 86 was released yesterday, but automatic updates are notified slowly during the first few days while Mozilla watches for any major problems. So you might not get it right away.


Firefox 85-86 has a preference to switch between the new print experience and the classic one. Here's where you can find that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch between true (new experience) and false (classic) -- here's what that looks like:

Læs dette svar i sammenhæng 👍 8

Alle svar (20)

more options

Valgt løsning

Hi Anan, Firefox 85 has a new print experience where the preview is integrated with the settings panel. It should appear if you choose Print from the menu or press Ctrl+P. Do you not get the overlay? What happens?

The double-sided printing problem -- short edge binding instead of long edge binding -- was a bug in Firefox 85 that should be fixed in Firefox 86 (according to this reply). Firefox 86 was released yesterday, but automatic updates are notified slowly during the first few days while Mozilla watches for any major problems. So you might not get it right away.


Firefox 85-86 has a preference to switch between the new print experience and the classic one. Here's where you can find that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch between true (new experience) and false (classic) -- here's what that looks like:

Nyttig?

more options

Thanks! This works to restore the previous convenience.

The "new" print pop-up looks exactly like the old Google Chrome air-print pop-up, which I have hated for years. What I especially miss is the "Simplify page" button that eliminates a lot of junk that I don't want to print. It makes stuff much more readable and saves many trees, not to mention toner cartridges.

Nyttig?

more options

There is a request on file to bring back the Simplify Page feature in a future update.

Nyttig?

more options

I SECOND THE MOTION!

Nyttig?

more options

How do we make this change Permanent?

I set print.tab_modal.enabled to "false" previously, and it has now changed itself back to "true"!

Nyttig?

more options

Slouch said

How do we make this change Permanent? I set print.tab_modal.enabled to "false" previously, and it has now changed itself back to "true"!

Wait, I swear I just replied to this post. ??

Do you have another preference containing print.tab_modal ? If so, set that one to false as well.

Nyttig?

more options

jscher2000 said

The double-sided printing problem -- short edge binding instead of long edge binding -- was a bug in Firefox 85 that should be fixed in Firefox 86 (according to this reply). Firefox 86 was released yesterday, but automatic updates are notified slowly during the first few days while Mozilla watches for any major problems. So you might not get it right away.

By the way, you also can set short-/long-edge binding manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste duplex and pause while the list is filtered

Firefox should list the print_duplex value for each printer. Printers you have not yet used in the new print experience will have a weird number that is not on this list:

  • 0 => print single-sided
  • 1 => print double-sided, with long-edge (portrait mode left-right) binding
  • 2 => print double-sided, with short-edge (portrait mode top-bottom) binding

To edit a value, double-click the current value to display an editing field. Change it as you wish, then press Enter or click the blue check mark button to save the change.

Nyttig?

more options

I followed the directions above and it made no difference even though "print.tab_modal" is set to false. I still do not get the classic print preview option. I might not mind so much but the only option I am given is to print in black and white. Many of the pages I want to print have color photos that I would like to have along with the web page.

Nyttig?

more options

anne said

I followed the directions above and it made no difference even though "print.tab_modal" is set to false. I still do not get the classic print preview option. I might not mind so much but the only option I am given is to print in black and white. Many of the pages I want to print have color photos that I would like to have along with the web page.

Just to confirm, the preference name is print.tab_modal.enabled (the name needs to be exact).

I don't know why yours did not switch. Are you on Windows? Usually the change is immediate and you can access Print Preview using either:

  • menu > Print
  • (menu bar) File > Print Preview

Nyttig?

more options

I am so pleased with Firefox - the best - but I really, truly wish that before (SURPRISE!!) making changes that drastically impact my and others' use , that so many of us are not tech capable of knowing how to change back - PLEASE let us know what changes have been made, and PLEASEPLEASEPLEASE give us a way to switch back to the "Classic" (previous) tool that we were so used to and really prefer.

I have absolutely HATEFUL Microsoft Outlook email that I have been unable to figure out how to change the % size of a printed out email. They print out in HUGE type, and I desperately wish I could find a way to scale the pages so I could make an email fit onto ONE sheet of paper in normal reading size (or smaller, for filing purposes) ....... which situation throws salt on the wounds of FF now dumping the old "PRINT PREVIEW" capability !!!!!

Nyttig?

more options

@jscher2000 -- THANK YOU for the direction above, but what appeared for me is attached - TWO places instead of only one to choose FALSE. I switched the lower one to FALSE, and it WORKS (YAY!!!) Should I change the first one to FALSE also, in addition to the lower one ? I am VERY GRATEFUL to you.

Nyttig?

more options

Note that you participate in a Shield study if you have app.normandy.startupRolloutPrefs.print.tab_modal.enabled = true. You can check that on the about:studies page.

Nyttig?

more options

THANK YOU SO MUCH for posting. I have wanted to pull my hair out this week with this stupid change to the print setting. Everything prints microscopic unless using system dialog. Why was this change even necessary? If it's not broke Mozilla , don't fix it.

Ændret af mhef den

Nyttig?

more options

jscher2000 said

anne said

I followed the directions above and it made no difference even though "print.tab_modal" is set to false. I still do not get the classic print preview option. I might not mind so much but the only option I am given is to print in black and white. Many of the pages I want to print have color photos that I would like to have along with the web page.

Just to confirm, the preference name is print.tab_modal.enabled (the name needs to be exact).

I don't know why yours did not switch. Are you on Windows? Usually the change is immediate and you can access Print Preview using either:

  • menu > Print
  • (menu bar) File > Print Preview

I went back and followed the instructions again. This time everything that came up when I did the tab_mo step was back to "true" so I changed them all to "false." Restarted Firefox and there is Print Preview back where it belongs! I am on Windows 7 Pro 64 bit. Yeah, it's old but I only change operating systems when I upgrade. I am a year behind my planned upgrade but I will need to keep this computer for at least a few more months. Thank you for getting me to check this setting again.

Nyttig?

more options

This Print Preview function is an extremely important one to me. I have a small business and 90% of orders require shipping packages. I use PP for making up packing slips, which saves a VAST amount of time in my case. I am using Win10/64bit. I can't express how extremely grateful I am for you here, who realize what changes that we "ordinary users" have had inflicted upon us and get that we aren't tech-savvy enough to figure out how to change back. And then you give your time to posting information, instructions and tips that are truly helpful. THANK YOU.

I booted up the PC to discover Print Preview was GONE - no notice, no explanation, no nothing. I am floored that FireFox would do this to us. I never considered that FF could be like other systems that force "Upgrades" on people who do not want them, nor know how to work around them. I can't thank FF enough for the safety and security upgrades, but I sure wish they would FIRST ASK us, "Do you want this or that" give us a menu of choices to opt in or stay out of !!

Ændret af timestreasures den

Nyttig?

more options

This suggested solution does not work!. I followed the instructions and changed the "print.tab_modal.enabled" to FALSE and closed Firefox. When I re-opened Firefox and looked at the "print.tab_modal.enabled" setting it still was shown as FALSE. However, the new Firefox print preview still appears. I want the old "classic" version. My Firefox version is 86.0 (64 bit). I am using Windows 10 Home, build 19041.vb release 19206-1406. The new Firefox print review is not a good upgrade for me...when will this problem be fixed so that the classic print preview appears automatically, every time??

Nyttig?

more options

Hi pageme2, normally you only need to change the top preference on your screenshot to false. No need to restart Firefox, the change should be immediate.

Did you try changing the second one as well?

Nyttig?

more options

I can never understand why, when something is perfectly ok, it's got to be updated or "improved". The "print preview" is something I go to whenever I print something. Saves a lot of paper by not printing something incorrectly. I have gone through the steps and got it back but after reading some comments have no confidence that it will be there tomorrow and I'll have to go through the steps again. Bring it back where it belongs and leave it alone. If you must play with it, make it an "option" to remove it, not add it. Most of us consider it a 'standard' part of the menu. I am not a fan of the new printing option at all.

Ændret af deputydufresne den

Nyttig?

more options

Hi deputydufresne, preview is now built into print. You can call that up using Print from the menu or the keyboard shortcut (Ctrl+P, or on Mac, Command+P).

Nyttig?

more options

How soon will we have a correction of the weirdness on duplex printing? (alternate pages are printed upside-down)

Nyttig?

  1. 1
  2. 2
  3. 3
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.