Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox hogging hard drive space with temp files (cubeb-shm...input/output)

  • 3 svar
  • 1 har dette problem
  • 67 visninger
  • Seneste svar af cor-el

more options

I've discovered that in my Users/UserName/AppData/Local/Temp folder, there are thousands of files eating up space with name "cubeb-shm-#####-#####-input" and "cubeb-shm-#####-#####-output", where "#####-#####" is a 10 digit number seperated by a hyphen.

I did a basic google search for these filenames and found several articles that talk about how firefox uses these, and normally creates and then deletes them, so there should only ever be one of each (input/output) file at a time. For some reason, I have thousands of these files, and they are eating up hundreds of Gb's of space on my hard drive. I only discovered this because my computer notified me I was running out of space. I manually deleted them, but I don't want to have to do this regularly, since it seems it's not expected behavior for Firefox.

I'm running the 64 bit version of Firefox 85.0.2, and there are no new updates available at the time of this writing. I'm really hoping someone can help me figure out how to get Firefox to appropriately manage these files. Help me Firefox community! You're my only hope!

Vedhæftede skærmbilleder

Valgt løsning

This issue should have been fixed for Firefox 87.

  • 1679500 - Firefox 84 creates thousands of `cubeb-shm-*` files in temp directory when I close RDP [87]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Læs dette svar i sammenhæng 👍 0

Alle svar (3)

more options

some problem,did you solve it?thanks for sys shadow,my computer still working

Ændret af fex2013 den

more options

See if this helps:

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

and whatever else you want.

Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

Valgt løsning

This issue should have been fixed for Firefox 87.

  • 1679500 - Firefox 84 creates thousands of `cubeb-shm-*` files in temp directory when I close RDP [87]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)