Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to connect to reCAPTCHA

more options

Hi, since today I've been unable to connect to reCAPTCHA. At first the reCAPTCHA boxes didn't show up at all and Firefox prevented me from connecting with Google because of an error with the certificate. I was able to fix that by allowing Firefox to trust root authorities (solution #6 on this list: https://sectigostore.com/page/fix-the-warning-potential-security-risk-ahead-error-in-firefox/ )

While the reCAPTCHA boxes are showing up again, I still can't connect with it. When checking the box, it starts loading for a while and I get an error message saying that there's no contact with reCAPTCHA and that I should check my connection and try again. I included a screenshot.

I went to topics of people who had the same problem and tried everything. Disabling protection against tracking, disabling Adblock, starting Firefox in safe mode, refreshing Firefox, loading another Firefox profile, restarting Firefox, uninstalling and reinstalling Firefox, restarting my pc. I'm desperate.

I'm only having this problem in Firefox, not in any other browser.

Vedhæftede skærmbilleder

Valgt løsning

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


Boot the computer in Windows Safe Mode with network support to see if that has effect.


You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy or VPN to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Læs dette svar i sammenhæng 👍 1

Alle svar (6)

more options

Oh, I'm not sure if it's related, but I just noticed I'm having a hard time connecting to Google Translate as well.

Nyttig?

more options

Could you take a look at whether any files are failing to load. You can open the Network Monitor tool in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

When you reload the page in the top part of the tab, Firefox should start listing all the files it is requesting, along with information about whether the request was successful. Is there any pattern of servers that Firefox cannot contact or which return failure codes (usually in the 400-500 range)?


Also, changing the certificate setting strongly implies that an intermediary is intercepting your browsing, although often this is just your security software or a proxy you use intentionally. To investigate who/what it is, check the certificate. Here's how:

right-click a blank area of the page > View Page Info > Security > View Certificate

Does the "Issued by" section refer to any of your security software vendors, or have any other pattern to it across sites?

Nyttig?

more options

All files seem to be loading.

As for the certificates: no, every website has its own issuer.

Screenshots included.

Nyttig?

more options

Valgt løsning

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


Boot the computer in Windows Safe Mode with network support to see if that has effect.


You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy or VPN to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Nyttig?

more options

Thanks. The page looks like it loaded normally. Do you see additional requests when you check the reCAPTCHA box? I'm attaching what I see.

Nyttig?

more options

cor-el said

You can check the connection settings.
  • Options/Preferences -> General -> Network: Connection -> Settings
If you do not need to use a proxy or VPN to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings":

This worked!

I don't know why it was set up to use the system proxy settings, but I changed it to "No Proxy". Can't believe it was something this stupid and simple.

Thanks to both of you!

Ændret af glennstakkestad den

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.