Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Performing a TLS handshake" delays pageloads forever

  • 2 svar
  • 1 har dette problem
  • 19 visninger
  • Seneste svar af cor-el

more options

Running W10 Pro on a new Dell XPS 15 (9500) - 1TB SSD, 32GB RAM. FF 83.0 (64-bit).

Recently I've been experiencing very long (30-60 second) delays when trying to load pages from < some > websites. Sometimes it will affect 5-10 sites; other times, only one or two. The message common to all (in the lower LH corner of my screen) is "Performing a TLS handshake..."

While some websites have off-and-on problems, this website consistently experiences long delays loading (and the TLS message): https://hymnary.org/

Any help?

Alle svar (2)

more options

BTW, these are my extensions -- but I hadn't added a new one for a while when this problem started happening:

more options

Try to disable IPv6 (check for other possible causes as well).


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window