Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot sign into Gmail, states this browser (Firefox) is not secure

  • 11 svar
  • 1 har dette problem
  • 64 visninger
  • Seneste svar af malnwick

more options

I hav been using my Gmail in Firefox with no problem until about 3 days ago. Now when I try to sign in to my account I get a pop up window which states “This browser or app may not be secure. Try using a different browser. Etc.”

I have tried another browser (chrome) and Gmail works fine, but I like working in Firefox. But at this rate I may dump Firefox and go to another browser.

I have looked through the other support group questions and solutions. I have tried them all and nothing is resolved. Clearing cache, clearing cookies, using a private window, managing data, using forget about this site, generating a new profile, disabling extensions, loading in safe mode, etc.

I have Firefox version 83.0 (64 bit). My operating system is windows 7.

Any other suggestions?

Margot

Alle svar (11)

more options

Can you inspect the certificate via a "View Certificate" button on the error page ? Who is the issuer of the certificate ?

Are you possibly using a VPN or proxy ?


You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Nyttig?

more options

The issuer of the certificate is Google Trust Services , common name GTS CA 101

I do not use vpn or proxy. I tried all the different proxy settings. Nothing worked, I still cannot sign in to Gmail.

Any other suggestions?

Thanks

Margot

Nyttig?

more options

Google Trust Services as the issuer should be OK.

You can try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Nyttig?

more options

Hi Margot, did you post your question using Safari on a Mac on an iPad -- or is your Firefox on Windows masquerading as Safari on Mac for some reason? That information -- your browser's user agent string -- could be one reason for a site to question your browser.

Nyttig?

more options

Cor-el

I tried changing the certificate as per the site you sent me. Still cannot access my Gmail.

JScherr

I posted my question on my iPad, but my problem is for my desktop computer where I work and use Firefox.

Margot

Nyttig?

more options

So far nothing I have tried seems to solve the issue. Should I try to uninstall my up to date Firefox and go back to an earlier version?? My concern would be the security would not be as good because it would not have the patches.

Margot

Nyttig?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Nyttig?

more options

Thank you Cor-el for more suggestions. I tried everything in the article you suggested.

Same problem, still cannot login to gmail as it states Firefox unsecure.

Very frustrating.

Nyttig?

more options

Are there any other suggestions as I still have the same problem of not being able to log into my gmail account in Firefox from my desktop computer.

Margot

Nyttig?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Nyttig?

more options

I already tried the forget this option and no change.

Margot

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.