Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Interactive Weather Radar Maps Not Working In Firefox

  • 14 svar
  • 2 har dette problem
  • 104 visninger
  • Seneste svar af chris.ihm

more options

One feature at www.weather.com (Weather Channel) is their "weather in motion" feature which loads interactive weather radars. For some reason, this is not working on my Firefox browser. It works fine in Chrome and Edge. The weather.com website loads just fine but the radar data (overlay on a map) will not load. IT WORKS FINE IN SAFE MODE. So i tried to disable all of my plug-in's, extensions and hardware acceleration in Firefox in regular mode. Still doesn't work. I created a new profile. Still doesn't work. I disabled the tracker feature in Firefox on that web page. Still doesn't work. I uninstalled and reinstalled Adobe Flash. Still doesn't work. Any ideas???

Firefox version 82.0 64 bit Running Windows 10 Professional

Valgt løsning

FIGURED IT OUT!!!

Turns out that my anti-virus software sometimes doesn't play well with some aspects of Firefox. Deep down there was a setting in the ant-virus software that I could adjust for some Firefox things. Once I adjusted that, the page works as expected.

Thank you for helping me....

Læs dette svar i sammenhæng 👍 0

Alle svar (14)

more options

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


What theme are you using? Try using the default.

Nyttig?

more options

You can check the Web Console for possible messages.

Nyttig?

more options

I am using the "default" theme. I switched to few other ones just to see. Nothing Changed. Also, when I click through the web console for messages, there are a whole bunch in red and yellow. I wouldn't begin to understand what those mean but I'm assuming somewhere in there, it is telling me what the problem is. At the end of the day, I can flip over to Chrome or Edge when I need that webpage - just thought I would see if folks who are smarter than me could quickly help me figure it out. Thanks...

Nyttig?

more options

I called for more help.

jlfptf said

. . . when I click through the web console for messages, there are a whole bunch in red and yellow.

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Nyttig?

more options

I have a similar problem. Many maps do not display. Attached is a screenshot of an attempt to show a radar map on WeatherUnderground. The basic local radar map shows the precip without the underlying location map. Safe mode made the problem go away. The only extensions running are ones that I have been using for years.

Update: On experimenting I found that removing the DuckDuckGo Privacy Essentials extension allowed the maps to appear. Not sure how I might have installed it -- have no recollection. Removed the extension.

Ændret af tigertimberhound den

Nyttig?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Nyttig?

more options

FredMcD - When I encountered this issue, the first thing I did was went to safe mode. When the page worked in safe mode, I went back into regular mode and disabled all of my add-on's and plug-in's (of which I have very few). I also turned off hardware acceleration. The page still didn't load properly. That's when I posted my original question. I've posted a screen shot down below. The image on the left is with Firefox. The image on the right is with Edge.

Nyttig?

more options

Boot the computer in Windows Safe Mode with network support to see if that has effect.


You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Nyttig?

more options

I booted Windows 10 into safe mode. While in windows safe mode, the webpage loaded correctly in Firefox. Most of those other suggestions are above my pay grade....

Thanks for trying to help though....

Nyttig?

more options

Valgt løsning

FIGURED IT OUT!!!

Turns out that my anti-virus software sometimes doesn't play well with some aspects of Firefox. Deep down there was a setting in the ant-virus software that I could adjust for some Firefox things. Once I adjusted that, the page works as expected.

Thank you for helping me....

Nyttig?

more options

That was very good work. Well Done.

Nyttig?

more options

I also had a problem on my Mac with Weather Channel and Weather Underground's Wundermap not loading on Firefox.

I launched Firefox in Safe Mode and the maps loaded with no problem. It turns out that the culprit preventing loading in my Firefox browser was the DuckDuckGo Privacy Essentials extension. Since disabling it, the maps are back for the first time in at least a year. I had searched for the answer to my issues for that entire period with no luck. Now I don't have to open another browser for a decent weather map.

I hope this will help some of my fellow Firefoxers.

Ændret af foxdawg den

Nyttig?

more options

Well done.

Nyttig?

more options

DuckDuckGo Privacy Essentials will block maps on Weather.com. When I "unprotect" weather.com in the drop-down menu, maps show up. On my Mac I do not have an anti-virus, and Firefox's settings for popup windows changed nothing, but Unprotecting weather.com worked for me.

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.