Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox loads homedepot.com webpages very slowly

  • 5 svar
  • 2 har dette problem
  • 50 visninger
  • Seneste svar af Rumboogy

more options

Firefox takes about 12 seconds to load homedepot.com webpages that are specific to products. Here is an example of a page that takes 12 seconds to load: https://www.homedepot.com/p/Milwaukee-15-Amp-1-1-4-in-Stroke-Orbital-SUPER-SAWZALL-Reciprocating-Saw-with-Hard-Case-6538-21/202101594.

I have tried removing all of my add-ons and this does not fix the problem.

Alle svar (5)

more options

The same website that I gave as example loads in 3 seconds using Safari so the issue is not with homedepot.com or my computer. It is with my installation of Firefox.

Nyttig?

more options

That page does seem slow to load.

Nyttig?

more options

The example site is not very fast on other browsers but it is exceedingly slow in Firefox. Is there a way to debug this? Something is clearly going wrong with my instance of Firefox.

Ændret af Rumboogy den

Nyttig?

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Nyttig?

more options

I deleted the cookies just for the homedepot.com website. This made no difference. It is very destructive to delete all cookies so I did not want to do that.

I then cleared the cache. This made no difference.

I then booted into safe mode. The problem changed. The website partially loaded more quickly such that at least it showed a picture. The full website still took too long to load (as compared to other browsers). This benefit was still present after restarting FF into normal mode.

As I said before, if I "refresh" FF (i.e. do a factor reset on it) then the problem goes away. Also removing the add-ons alone does not fix the issue. So the problem clearly is with some data that has been previously loaded in FF and is now stored. It is not fixed by clearing the cache or by clearing the homedepot.com cookies. But when you load homedepot.com many other domains are loaded as well and they all have cookies so it seems like the issue is in these 3rd party cookies.

So I guess the question is can I delete all cookies that are loaded directly and by 3rd parties from homedepot.com without deleting ALL cookies which will cause a host of other issues?

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.