Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable search for single word hostname

  • 2 svar
  • 1 har dette problem
  • 21 visninger
  • Seneste svar af DreaSpirit

more options

To make sure I'm using the correct terms, I'd like to enter a single word into the address bar and not get the notification "Did you mean to go to....". My answer is always "no", I just want it to search as normal. This only started happening in the past year or so.

I tried the solution given at https://support.mozilla.org/en-US/questions/1266960 but it didn't work.

Thanks!

To make sure I'm using the correct terms, I'd like to enter a single word into the address bar and not get the notification "Did you mean to go to....". My answer is always "no", I just want it to search as normal. This only started happening in the past year or so. I tried the solution given at https://support.mozilla.org/en-US/questions/1266960 but it didn't work. Thanks!

Alle svar (2)

more options

As you may know, when you run a single word search, Firefox checks in the background whether there is a server at that address. This is useful to find servers on your internal network, such as http://intranet/.

If you get this bar all the time, it usually indicates that your current DNS service provider is dishonest. An honest DNS will tell Firefox your query text is not a known hostname. But dishonest DNS services will send Firefox an address of a server that hosts pay-per-click advertising to "help" you find what you're looking for. Perhaps you've seen such a page if you ever typo'd an address.

To investigate further, I generally suggest trying something like:

http://no-way-this-exists/

If you get a page of search results, check for a link near the upper right or at the bottom like:

  • Opt out
  • Why am I getting this page

That usually leads to information on who/what is causing the problem and how to disable this function.


Recently, a new option was added to completely turn off this background checking. So if you don't have the energy to address the DNS provider angle, this could be good enough for you for now.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste dns and pause while the list is filtered

(3) Double-click the browser.urlbar.dnsResolveSingleWordsAfterSearch preference to display an editing field, and change the value from 1 to 0 then press Enter or click the blue check mark button to save the change.

For reference:

  • 0 = never check
  • 1 = check in certain cases (default)
  • 2 = always check

Another option, if you don't rely on a local hosts file, is to use DNS over HTTPS or another DNS provider: Firefox DNS-over-HTTPS.

more options

Hi jscher2000,

Thanks for your reply. I'll give your suggestion a try (at a later time) and let you know if I'm successful.

I'm not familiar with the term DNS or even what a "local hosts file" is. I'll do some research and learn a bit.

Thanks again! -Andre'a