Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

OK Button greyed out on all file downloads

  • 8 svar
  • 1 har dette problem
  • 21 visninger
  • Seneste svar af mark-k1

more options

Similar to this article, "https://support.mozilla.org/en-US/kb/cant-download-or-save-files" I am unable to download any files via browser. I am up to date on versioning (Windows 10, v81.0 64-bit), and I tried all of the steps in the article.

I have also tried resetting the "security.dialog enable_delay" value (it was correct at 1000) to 0 and downloads worked again, but setting it back to 1000 (or even 500) and the problem returns.

I also noticed that whether or not I have the General Option set to "use this folder" or "ask each time", I get the same dialog box and the OK button is greyed out.

Vedhæftede skærmbilleder

Alle svar (8)

more options

In the box, try clicking on something. Any difference?

Nyttig?

more options

Hi Fred: I tried a number of things: clicking on the greyed out OK button (nothing happened), clicked on the various options (option selected correctly but could not execute due to greyed out ok), and of course Cancel dialog button worked fine.

Also tried waiting and extended period of time for the button to "ungrey" but after 5 minutes gave up on that; also tried same web page download of file under Edge and worked fine (so no external blockages).

Finally, setting the delay to 0 immediately enabled the button and everything worked as normal with no other change. Setting delay to any positive integer immediately causes the same behaviour (greyed OK).

Nyttig?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

What delay setting are you talking about?

Nyttig?

more options

Hi Fred: the setting is "security.dialog enable_delay" (the delay value is in milliseconds, and normally set to 1000 - 1 sec), found in "about:config".

I don't want to mark this as resolved since even though that fixes the behaviour it introduces a security problem that the setting was intended to resolve. Nothing I have read indicates its a good idea to set the value to 0 (no delay) except as a last resort or workaround; instead there a multiple indications this is a bad idea in general. Would prefer to either escalate this as a new bug or find a resolution so it works as designed - downloads work after the "OK" button gets the blue box around it, 1000ms after the dialog starts.

BTW - this was working properly until very recently - I cannot tie it directly to an update or any other change as I just noticed the downloads not working today.....I had never heard of any of these settings prior to today!

Nyttig?

more options

I called for more help.

Nyttig?

more options

Fred: thanks for your help so far! One other item that I should mention just happened: I purchased some music in digital format and the store sent a link with a download button.....I expected to have the same problem but that download worked correctly: I got the dialog box with the options and the OK button was *not* greyed out.....the download worked fine.

However I went back to a number of other downloads I had tried while investigating this problem and they still have the same behavior - greyed out OK button.....

Nyttig?

more options

Is the problem with all websites/pages, some, a few?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Nyttig?

more options

Hi Fred: tried all of the above in order, after each step retesting to see if anything helped. In short, no progress.

Any site I have attempted to click on a download link of any sort has failed; even the link in the email from the store where I bought my music failed; so the only success I have had was the fluke of the direct download from having purchased the music (I suspect that was the outlier!).

Oh, and I went back and retested by setting security.dialog enable_Display to 0 again and everything works properly and as expected, including the link from the music store.

I'm going to turn the hardware acceleration back on now; looking forward to any other thoughts you might have.....

In summary: none of the suggestions have caused the behaviour to change; I had a fluke with a direct download from a single site that I cannot reproduce; I can eliminate the issue in all test cases by setting the security.dialog enable_display to 0; all of the above are reproducible. I have also tried restarting firefox between changes to ensure that changes were properly implemented, and I have restarted the workstation multiple times throughout this exercise....

Mark

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.