Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Font rendering poorly in Firefox only

  • 8 svar
  • 1 har dette problem
  • 12 visninger
  • Seneste svar af wynden

more options

Hello,

I have a website on Wordpress that uses google fonts (called via css). The fonts have always worked perfectly up until very recently when I noticed they started rendering improperly. I checked other browsers and found that the fonts render fine in Chrome but not in Firefox or the Firefox-based Pale Moon browser.

I've included screen shots from Firefox 80.0.1 (my default) and Chrome. The Firefox screen can be differentiated by the "Edit this post" link.

The most confounding aspect, to me, is that this is a recent development as they used to render in all browsers without issue. Would anyone have any insight into what may be causing this?

Vedhæftede skærmbilleder

Alle svar (8)

more options

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Nyttig?

more options

Hi Fred,

Thanks for the reply. Unfortunately that option is already checked in my browser preferences. And the font is showing up, just badly.

Nyttig?

more options

What is the name of that font? I'd like to look at its page on the Google Fonts site.

Nyttig?

more options

Hi jscher,

It's called, "Cinzel".

Nyttig?

more options

I checked some of those words on Google Fonts and the results are not beautiful at 16px (larger sizes seem better) but the characters are more consistent. I've attached a screenshot.

Firefox relies on Windows' ClearType for font smoothing. Have you made any changes to ClearType settings?

Nyttig?

more options

Thank you, jscher. No, I have not, to my knowledge, made changes to the ClearType settings. Since everything rendered fine when I initially set it up, I thought perhaps there was a change in a recent Firefox update that may be causing it.

Nyttig?

more options

One possible reason for Firefox to perform worse in font rendering is if hardware acceleration of graphics is disabled. I'm not sure how to confirm whether that is the current status, although there is a setting you could check to make sure it is not disabling that way: Firefox's performance settings.

Nyttig?

more options

Well I do have "Use recommended settings" checked under Performance in Firefox, and when I uncheck that it shows hardware acceleration "use[d] when available". Not sure what else to look for to that end, either.

I would prefer the font to work as intended, but it's not a huge issue. I will keep fiddling with it and see if adjusting the size or choosing a different font may help.

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.