Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Platform version error

  • 1 svar
  • 1 har dette problem
  • 91 visninger
  • Seneste svar af cor-el

more options

I had setup file association for html files to Firefox on Windows 10. Recently, when I tried to run Belarc Advisor, I received an error message saying:

XULRunner Error: Platform version '78.0.2' is not compatible with minVersion <= 78.0.1 maxVersion <= 78.0.1

I am able to temporarily resolve it by changing html file associations to Chrome but it seems like the issue is with Firefox installations. I had previously inquired about issues with Firefox automatic updating and was advised to do a complete install. I did that and am at version 79.0 at this time.

The following post indicates that XULRunner errors are caused by "Incomplete Update: The main reason for this error is an incomplete installation/update of the Firefox browser. Firefox is usually set to automatically install updates and this process can be interrupted because of bad internet or a sudden system shutdown or an antivirus. Whenever this happens, your Firefox update doesn’t install completely and leaves you with an installation with a mixture of old and new updated files in the Firefox program folder."

Source: https://appuals.com/fix-xulrunner-error-platform-version-is-not-compatible/

Is their solution the best approach to cleaning up this update issue?

I had setup file association for html files to Firefox on Windows 10. Recently, when I tried to run Belarc Advisor, I received an error message saying: XULRunner Error: Platform version '78.0.2' is not compatible with minVersion <= 78.0.1 maxVersion <= 78.0.1 I am able to temporarily resolve it by changing html file associations to Chrome but it seems like the issue is with Firefox installations. I had previously inquired about issues with Firefox automatic updating and was advised to do a complete install. I did that and am at version 79.0 at this time. The following post indicates that XULRunner errors are caused by "Incomplete Update: The main reason for this error is an incomplete installation/update of the Firefox browser. Firefox is usually set to automatically install updates and this process can be interrupted because of bad internet or a sudden system shutdown or an antivirus. Whenever this happens, your Firefox update doesn’t install completely and leaves you with an installation with a mixture of old and new updated files in the Firefox program folder." Source: https://appuals.com/fix-xulrunner-error-platform-version-is-not-compatible/ Is their solution the best approach to cleaning up this update issue?
Vedhæftede skærmbilleder

Alle svar (1)

more options

Like stated in the article, this is caused by an incomplete update where some (.ini) files are from the previous Firefox version. This is usually a problem caused by security software that keeps a handle on some files.

Best is to do a clean reinstall and remove the current Firefox program folder to ensure that no files are left and reinstall a freshly downloaded Firefox installer.

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.