Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

userChrome.css has no effect

  • 4 svar
  • 1 har dette problem
  • 1183 visninger
  • Seneste svar af mbrowne83

more options

Hello,

Ultimately, I want to change the font for unread email in my in-basket, same as [thread]. Nothing I do in userChrome.css seems to have any effect. I'm running Windows 10. %AppData% = "C:\Users\Ron.000\AppData\Roaming".

Accordingly, I've placed userChrome.css here: C:\Users\Ron.000\AppData\Roaming\Thunderbird\Profiles\xdl9kae3.default\chrome


I have toggled toolkit.legacyUserProfileCustomizations.stylesheets to true

Current content of the file is below. Thunderbird v68.11.0: /*

* Do not remove the @namespace line -- it's required for correct functioning
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

/* Threads Pane font */ .tree-rows {

   font-size: 48pt !important;
   font-family: Verdana !important;
   color: #000062 !important;

}

Valgt løsning

Turns out I was using the wrong profile directory. Apparently the active one is named <hex number>.default-release. I had tried this directory before, but under AppData/Local :-}

With that sorted, code above works.

Thanks

Læs dette svar i sammenhæng 👍 0

Alle svar (4)

more options

Not sure what happened to that link: https://support.mozilla.org/en-US/questions/1261363

more options

This code is working in TB 78:

#threadTree treechildren::-moz-tree-cell-text(unread) {
-moz-appearance: none !important;
color: #2492d1 !important;
font-weight: bold !important;
font-family: Verdana !important;
font-size: 18pt !important;
}

If you choose a large size like 18 or 48pt, you might want to add a height declaration:

#threadTree treechildren::-moz-tree-row {
height: 25pt !important;
}

Make sure your userChrome.css file type is Cascading Style Sheet.

more options

Valgt løsning

Turns out I was using the wrong profile directory. Apparently the active one is named <hex number>.default-release. I had tried this directory before, but under AppData/Local :-}

With that sorted, code above works.

Thanks

more options

Important note: If you are using a more recent version of Thunderbird (I'm on Thunderbird 78 currently) and you've never created a userChrome.css file for your profile before, you'll need to enable the `toolkit.legacyUserProfileCustomizations.stylesheets` setting in Config Editor.

See this page for how to access Config Editor from Thunderbird Preferences: https://support.mozilla.org/en-US/kb/config-editor