Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

some MP4 not working at all in FF

  • 13 svar
  • 1 har dette problem
  • 18 visninger
  • Seneste svar af jscher2000

more options

Some optimized mp4 do not play at all in any of my FF. From what I can see, this video is 10 fps and description says "Optimized using ezgif.com". Small and short videos. Lenghts seems to be correctly indicated by FF player frame.

All other MP4 play perfectly in any of my FFs. When I download such mp4 to my computer, VLC will play it normally. Any FF at this same computer will not! I repeat: all other videos play perfectly normal, including any MP4 I tried! Anything else on this same site plays normally. I am on Win 7.

I remove all security features I can, still, this single sort of videos are not playing and this is true for any such videos on this site. I tried 4 different versions of FF (v29, 60.9.0esr, v65 IceDragon, v71). They inherit configuration from the existing ones, so they are not clean installs. The same problem I have in several Win7 computers (two Virtual Machines and a real computer, not Win 7 N). FF safe mode does not help also.

Example page containing such mp4 with a cat: https://www.index.hr/lajk/poster/227148/vlasnici-su-snimili-svoju-smijesnu-macku-koja-se-moze-provuci-i-kroz-najmanji-prostor

and when I isolate just the video:

https://storage-lajkhr.index.hr/kiki/a727a5a6-734f-44d6-9ee8-42b857f22193.mp4

in FF I get only an empty black page and frame with player and no video at all.

What is wrong here?

Alle svar (13)

more options

It's working in version 80, win 10.

We can't say anything about those archaic versions you mentioned. Firstable I'd suggest you to update to a recent version.

Nyttig?

more options

No, I am trying to avoid new versions for many years now. I need something that might work in a backup VM Win 7 on my servers.

New versions are security risk as they introduce new problems all the time, are much slower and break backups. Also, I prefer not to buy a new computer every year again. I do not see how a version made this year can be called archaic. That means the program is terrible :)

Ændret af asv01 den

Nyttig?

more options

But, since I asked for help... I downloaded and sandbox installed current version. Nothing changed. These videos do not play for me on this non-archaic version, too.

Nyttig?

more options

OK. Open a WWW Console (Ctrl + Shift + K) and try to run a video. There should show up an error about it.

Nyttig?

more options

Works for me in Firefox 52 ESR and 60 ESR and newer, so it looks like something on your setup.

You can check the Web Console for media related messages and make sure you have proper support for playing MP4.

Nyttig?

more options

If I try to paste only the offending video link: https://storage-lajkhr.index.hr/kiki/a727a5a6-734f-44d6-9ee8-42b857f22193.mp4

WWW Console does not do or say absolutely anything. Black square player frame with the length is only shown. I tried everything else, so the problem is with this particular format. I think something is not working at the OS level (Win7). So I went on to recheck my initial statement and found I was not perfectly precise! If I try to play this downloaded video from my computer using VLC (or other players) it plays perfectly fine. Just as any other MP4 video.

But, if I try to play this downloaded video using the "Windows Media Player" which (I guess) comes with the Windows, then I can replicate the same behavior as in FF: almost all other MP4 videos play perfectly, but these tiny ones which look more like animated GIFs with 10 fps do not play at all.

So, it looks like FF is using the same engine as the inbuilt "Windows Media Player". But I am unable to find how to point FF to something else which would work as evidenced by all the other players on the PC.

Nyttig?

more options

Nyttig?

more options

As I said, I tried all of the above. This and all similar videos are not playing embedded using FF and in "Windows Media Player".

At the same computer, VLC plays these videos perfectly just as FF and any other player do play any other mp4 perfectly.

All online tests regarding MP4 I could find claim everything is perfectly OK with the FF.

Ændret af asv01 den

Nyttig?

more options

The video codec must be the same.

Perhaps you could find something like "win7 codec pack" or "media player codec pack" and update your codecs.

Nyttig?

more options

Nyttig?

more options

Tried but nothing is available for regular Win 7. I just tried to manually install FFmpeg. New profile does not help, too.

The above page says: MP4/H.264 avc1.42001E, mp4a.40.2 probably WebM VP8 vp8.0, vorbis probably

and all other - supported.

Nyttig?

more options

Can I not say somehow to FF I want to use VLC as a player for embedded mp4 videos? That would solve the problem.

Nyttig?

more options

As a data point, it plays on Windows 10 x64 in Firefox 78. Maybe there is a difference in decoding support on Media Foundation in Windows 7 compared with Windows 10?

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.