Search Support

HTML forms

  • 12 svar
  • 1 har dette problem
  • 21 visninger
  • Seneste svar af cor-el

more options

As of yesterday my forms with HTML are not working properly. It is not carrying the hidden ! parameter. No problem with chrome. If i display the parameter there is nothing there. HELP! thank you

All Replies (12)

more options

Hi margaretmbreen, I'm not what you mean by

It is not carrying the hidden ! parameter.

Is it a problem with a hidden input such as

<input type="hidden" value="something">

not being sent to the server in a POST request body? or something else?

Helpful?

more options

yes....this is one that does not work:

Annual Highlights Maintenance

<form method='post' action='highlightsMtce.php'> <input type='hidden' name='!' value='ADD' /> <select name='ID' ></select>

Select Member for an Individual Highlight:
       <input type="radio" name="cap" value='member' checked > <select name='ghin' ></select>
Or
<input type="radio" name="cap" value='other' >Other info

<input class='sub' type='submit' value='Add Highlight' /> </form>

THe code that processess does a switch on the !=ADD value and it goes to the default instead. displaying the ! just before the switch shows no value.

Helpful?

more options

margaretmbreen said

yes....this is one that does not work: ... <input type='hidden' name='!' value='ADD' />

I don't recall all the rules for names and IDs, but have you tested using an alphanumeric name instead of a symbol? You could name it bang which is one way people reference the exclamation point.

Helpful?

more options

I had not seen that rule for names before and have been using ! widely....I will try your suggestion, but BTW, it is working in some of my forms and seems to be working fine with GET vs POST. And as I did mention, worked until yesterday which leads me to believe something changed in firefox (which of course could be tightening of a rule)

Helpful?

more options

I tried changing it from ! to todo....still did not work. Also if i try to display the item (using echo with php) for the $_POST["todo"] i get an unidentified index notice...

Helpful?

more options

Do you think your Firefox updated yesterday? That shouldn't cause a field to be omitted from a POST.

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

I oppened a second copy of firefox in same mode and it worked.

Then went back to first instance of firefox and it also worked....how can I tell if it is in safe mode?

Helpful?

more options

margaretmbreen said

I oppened a second copy of firefox in same mode and it worked.

If you still had a window open in regular mode, the new window should also be in regular mode. Restarting in Safe Mode requires closing all the existing windows.

Then went back to first instance of firefox and it also worked....how can I tell if it is in safe mode?

One way is: Safe Mode disables all the extensions, so when you look at the toolbar in Safe Mode, all those buttons are missing.

Helpful?

more options

I got there myself also.....so conclusion is that in safe mode it works correctly. what next?

Helpful?

more options

One of your extensions may be blocking the field. Do you have anything privacy related that could be doing that?

Helpful?

more options

The only extension i have is a mcaffee web advisor which I can get rid of.

my protection level is standard. below is what i saw..graph did not copy, but a lot of blocks today.


Enhanced Tracking Protection

Trackers follow you around online to collect information about your browsing habits and interests. Firefox blocks many of these trackers and other malicious scripts.

Protection Level is set to Standard

Does this help?

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

- - - - You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.