Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do you turn off the 1 click selects all in the URL bar?

  • 3 svar
  • 1 har dette problem
  • 12 visninger
  • Seneste svar af Danny Colin

more options

Single clicking the URL bar selects the entire contents, making it behave unlike any text in web forms or, frankly, pretty much anywhere else in the system. There used to be a pair of config options described two year ago here to control this behavior, but that solution no longer works.

I'm sure the developers believed in good faith they were saving me time, but making the URL (and Search) bars behave differently from every other text box on the system, in and out of the browser, is not helpful. I'm forever having to correct for this erroneous feature, and it's getting old.

Is there any way in 76.0 to make the URL bar behave like other text boxes on the (Linux) system, or must all platforms (mis)behave like Windows?

All Replies (3)

more options

Sadly, it's no longer possible to disable the "click to select all" behavior since 76. See bug 1621570 for discussion of the removal of this preference and especially comment 7 that gives the reasoning behind it.

Helpful?

more options

Thanks, Danny. One less reason to stick with Firefox over Chrome. Sad times.

Helpful?

more options

Todd Lewis said

One less reason to stick with Firefox over Chrome. Sad times.

Chrom(ium) has the select-all-URL behavior for ages. So switching to it won't solve your issue. Firefox was one of, if not, the only browser respecting the Linux input behavior.

Helpful?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.