X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Problem since installing version 68.6.0

Skrevet

A couple of days ago when I loaded Thunderbird, I was invited to upgrade to version 68.6.0 from (I think) version 60.9.1, which I did. I was then invited to close Thunderbird and reopen it. All looked OK at that stage until I tried to send an e-mail, when I got an error message saying that my (or maybe my ISP's) Peer Certificate was unacceptable. Some research on the Internet did not produce any directly relevant answers but somehow I managed to create an exception and have been able to send and receive e-mails OK ever since.

However, I then noticed that my inbox had a big gap in it from 17th November 2019 (which is when I first imported my data from Outlook 2003 and started to use Thunderbird) to 24th March 2020. Additionally, all my local folders with the exception of Trash, Outbox and seven "Outlook Import" folders had disappeared. Likewise all my Sent data and Trash data before 24th March had disappeared. Finally, my calendar data has also disappeared.

I had previously noticed but not questioned that if I navigated C:\ Users\...\AppData\Local\Thunderbird\Profiles that there were two gobbledegook sub-folder names in the Profiles folder. I do not have a record of their previous names but did notice that one had not updated its date / time stamp since around 17th November 2019 and that the other appeared to update every time I used Thunderbird. I had meant to raise a query on the forum about this as they are taking up a lot of disk space and was wondering if they could be merged and one deleted but it was a low priority and I never did so.

The current sub-folder names are: <2henlgcu.default-release>, which updates its date / time stamp every time I use Thunderbird and <qpqlfjsy.default> which has not updated since 24th March.

Can anybody please help me to get back my missing data as well as merge the more recently sent / received e-mails with it?

Regards and TIA

Phil

A couple of days ago when I loaded Thunderbird, I was invited to upgrade to version 68.6.0 from (I think) version 60.9.1, which I did. I was then invited to close Thunderbird and reopen it. All looked OK at that stage until I tried to send an e-mail, when I got an error message saying that my (or maybe my ISP's) Peer Certificate was unacceptable. Some research on the Internet did not produce any directly relevant answers but somehow I managed to create an exception and have been able to send and receive e-mails OK ever since. However, I then noticed that my inbox had a big gap in it from 17th November 2019 (which is when I first imported my data from Outlook 2003 and started to use Thunderbird) to 24th March 2020. Additionally, all my local folders with the exception of Trash, Outbox and seven "Outlook Import" folders had disappeared. Likewise all my Sent data and Trash data before 24th March had disappeared. Finally, my calendar data has also disappeared. I had previously noticed but not questioned that if I navigated C:\ Users\...\AppData\Local\Thunderbird\Profiles that there were two gobbledegook sub-folder names in the Profiles folder. I do not have a record of their previous names but did notice that one had not updated its date / time stamp since around 17th November 2019 and that the other appeared to update every time I used Thunderbird. I had meant to raise a query on the forum about this as they are taking up a lot of disk space and was wondering if they could be merged and one deleted but it was a low priority and I never did so. The current sub-folder names are: <2henlgcu.default-release>, which updates its date / time stamp every time I use Thunderbird and <qpqlfjsy.default> which has not updated since 24th March. Can anybody please help me to get back my missing data as well as merge the more recently sent / received e-mails with it? Regards and TIA Phil
Citér

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Yderligere information

Luk
Matt
  • Top 10 Contributor
  • Moderator
3427 løsninger 23795 svar

Valgt løsning

I think this will help. https://thunderbirdtweaks.blogspot.com/2019/09/i-lost-my-profilemail-on-update-to.html
Fandt du dette nyttigt?
Citér
Stans
  • Top 25 Contributor
26 løsninger 168 svar

Don't worry about the folders in C:\ Users\...\AppData\Local\Thunderbird\Profiles, they are primarily used for cache data. Thunderbird profiles are stored in C:\ Users\...\AppData\Roaming\Thunderbird\Profiles and this is where you need to pay attention to. It sounds like you now have two versions of Tbird installed, 60 and 68. Starting with version 67, release versions of Tbird use a profile folder with the .default-release suffix. Previous versions just used the .default" suffix. Your old profile is qpqlfjsy.default while the new and currently in use (i believe) is 2henlgcu.default-release. What I don't understand is how parts of the old profile got migrated to the new profile, or did you have to re-add your accounts?

Anyway, navigate to C:\ Users\...\AppData\Roaming\Thunderbird\Profiles. Confirm that there is a qpqlfjsy.default folder (old profile folder), then use the profile manager to recreate/recover the old profile as described here http://kb.mozillazine.org/Recovering_a_missing_profile#Using_the_Profile_Manager_to_recover_a_profile

See http://kb.mozillazine.org/Profile_Manager#Accessing_the_Profile_Manager for how to access the profile manager.

We'll address the size of the cache locations and merging messages between the two profiles afterwards.

Don't worry about the folders in C:\ Users\...\AppData\'''Local\Thunderbird\Profiles''', they are primarily used for cache data. Thunderbird profiles are stored in C:\ Users\...\AppData\'''Roaming\Thunderbird\Profiles''' and this is where you need to pay attention to. It sounds like you now have two versions of Tbird installed, 60 and 68. Starting with version 67, release versions of Tbird use a profile folder with the ''.default-release'' suffix. Previous versions just used the ''.default" suffix. Your old profile is qpqlfjsy.default while the new and currently in use (i believe) is 2henlgcu.default-release. What I don't understand is how parts of the old profile got migrated to the new profile, or did you have to re-add your accounts? Anyway, navigate to C:\ Users\...\AppData\'''Roaming\Thunderbird\Profiles'''. Confirm that there is a qpqlfjsy.default folder (old profile folder), then use the profile manager to recreate/recover the old profile as described here http://kb.mozillazine.org/Recovering_a_missing_profile#Using_the_Profile_Manager_to_recover_a_profile See http://kb.mozillazine.org/Profile_Manager#Accessing_the_Profile_Manager for how to access the profile manager. We'll address the size of the cache locations and merging messages between the two profiles afterwards.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Matt's suggestion solved the problem admirably so I didn't need to go to the second stage as suggested by Stans.

However, I will now be grateful for the offered assitance in resolving the size of the cache locations and merging messages between the two profiles.

Regards and TIA

Phil

Matt's suggestion solved the problem admirably so I didn't need to go to the second stage as suggested by Stans. However, I will now be grateful for the offered assitance in resolving the size of the cache locations and merging messages between the two profiles. Regards and TIA Phil
Fandt du dette nyttigt?
Citér
Stans
  • Top 25 Contributor
26 løsninger 168 svar

Thunderbird has inbuilt cache management options, so just load the profile whose cache location you wish to clear, then go to Tools > Options > Advanced > Network & Disk Space > Disk Space. You will see how much disk space the cache is using and a button to manually clear the cache on demand or whenever you want. Click it. Do the same for the other profile. Since you're now familiar with using the about:profiles link under Help > Troubleshooting Information, launching the other profile should be a piece of cake.

To transfer messages from one profile to the other, I highly recommend an add-on called ImportExportTools NG. Install it on both profiles then restart both Thunderbird profiles/instances (in the about:profiles tab, at the top-right, there is a section called Restart. Below it, there is a Restart normally button that will gracefully restart Tbird). You will now be able to use the add-on to copy the desired messages from one profile to the other. For example, select the recently sent messages, then right click them and choose Save selected messages > as Mbox file (new). Choose a convenient location where the mbox file will be saved, type a befitting name for it then click Save. I recommend the Mbox file format for exporting multiple messages or whole folders. The status bar will show you the progress of the export process. Once finished, switch to the other (destination) profile, right-click the destination folder into which you want to import the messages, for example Sent, select the ImportExportTools NG > Import mbox file options and proceed from there. Should be smooth-sailing going forward.

Thunderbird has inbuilt cache management options, so just load the profile whose cache location you wish to clear, then go to '''Tools > Options > Advanced > Network & Disk Space > Disk Space'''. You will see how much disk space the cache is using and a button to manually '''clear''' the cache on demand or whenever you want. Click it. Do the same for the other profile. Since you're now familiar with using the ''about:profiles'' link under Help > Troubleshooting Information, launching the other profile should be a piece of cake. To transfer messages from one profile to the other, I highly recommend an add-on called '''ImportExportTools NG'''. Install it on both profiles then restart both Thunderbird profiles/instances (in the about:profiles tab, at the top-right, there is a section called ''Restart''. Below it, there is a '''Restart normally''' button that will gracefully restart Tbird). You will now be able to use the add-on to copy the desired messages from one profile to the other. For example, select the recently sent messages, then right click them and choose '''Save selected messages''' > as Mbox file (new). Choose a convenient location where the mbox file will be saved, type a befitting name for it then click Save. I recommend the Mbox file format for exporting multiple messages or whole folders. The status bar will show you the progress of the export process. Once finished, switch to the other (destination) profile, right-click the destination folder into which you want to import the messages, for example Sent, select the '''ImportExportTools NG > Import mbox file''' options and proceed from there. Should be smooth-sailing going forward.

Ændret af Stans den

Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.