X
Tryk her for at gå til webstedets mobilversion.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Supportforum

Getting this error message: The message could not be sent because the connection to Outgoing server (SMTP) smtp.gmail.com was lost in the middle of

Skrevet

I keep getting this error message when trying to send emails through one of my Gmail accounts in Thunderbird: "Sending of the message failed. The message could not be sent because the connection to Outgoing server (SMTP) smtp.gmail.com was lost in the middle of the transaction. Try again." I tried the steps online in the support article at https://support.mozilla.org/en-US/kb/cannot-send-messages. All my settings are correct, but my emails will not send all of a sudden. I tried switching the port to 587, but still got the same message.

I'm sending a screenshot of my server settings. My email provider: Gmail ISP: Spectrum Firewall Version: Windows Defender Firewall Antivirus Software: Windows Defender Virus & Threat Protection Operating System & Version: Windows 10 Home, Version 10.0.18362 Build 18362 Thunderbird Version: 68.5.0 (32-bit)

I keep getting this error message when trying to send emails through one of my Gmail accounts in Thunderbird: "Sending of the message failed. The message could not be sent because the connection to Outgoing server (SMTP) smtp.gmail.com was lost in the middle of the transaction. Try again." I tried the steps online in the support article at https://support.mozilla.org/en-US/kb/cannot-send-messages. All my settings are correct, but my emails will not send all of a sudden. I tried switching the port to 587, but still got the same message. I'm sending a screenshot of my server settings. My email provider: Gmail ISP: Spectrum Firewall Version: Windows Defender Firewall Antivirus Software: Windows Defender Virus & Threat Protection Operating System & Version: Windows 10 Home, Version 10.0.18362 Build 18362 Thunderbird Version: 68.5.0 (32-bit)
Vedhæftede skærmbilleder

Valgt løsning

There is too much changing of settings. First, delete all entries in Tools/Options/Security/Passwords/Saved Passwords. Press Alt if the Menu Bar with Tools is hidden, or click the 3-bar icon, Options/Options/Security/Passwords/Saved Passwords.

Next, use these settings for IMAP accounts: imap.gmail.com on port 993, SSL/TLS, OAuth2 authentication, User Name = email address. For POP accounts: pop.gmail.com on port 995, SSL/TLS, OAuth2 authentication, User Name = email address. For SMTP: smtp.gmail.com on port 465, SSL/TLS, OAuth2 authentication, User Name = email address.

After you've deleted the passwords, restart TB and enter the regular account password, not an app password, in the OAuth browser window when prompted.

Læs dette svar i sammenhæng 1
Citér

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36

Yderligere information

Luk
sfhowes
  • Top 10 Contributor
2012 løsninger 10078 svar

Since you appear to have multiple gmail accounts, check that each account is sending on the correct smtp: select an account in the left pane of Tools/Account Settings, then click Edit SMTP server... in the lower right pane, and confirm that the User Name of the smtp is the same as that for the selected account. If not, choose the correct smtp from the drop-down menu. It helps if you give each gmail smtp a distinct Description, e.g. gmailpersonal, gmailbusiness etc.

If that's all correct, Remove the passwords and oauth tokens from Tools/Options/Security/Passwords/Saved Passwords, restart TB, and enter the regular account password in the OAuth browser window when prompted. The smtp settings in your picture are correct.

Since you appear to have multiple gmail accounts, check that each account is sending on the correct smtp: select an account in the left pane of Tools/Account Settings, then click Edit SMTP server... in the lower right pane, and confirm that the User Name of the smtp is the same as that for the selected account. If not, choose the correct smtp from the drop-down menu. It helps if you give each gmail smtp a distinct Description, e.g. gmailpersonal, gmailbusiness etc. If that's all correct, Remove the passwords and oauth tokens from Tools/Options/Security/Passwords/Saved Passwords, restart TB, and enter the regular account password in the OAuth browser window when prompted. The smtp settings in your picture are correct.
Fandt du dette nyttigt? 0
Citér

Spørgsmålsstiller

Yes, I have two Gmail accounts. I checked the SMTP server settings for them again and they both had the correct corresponding username. One of my Gmail accounts is working perfectly fine, thankfully, but the other one isn't. I could not find a "Passwords" option under "Tools/Options" (screenshot attached). I went to "Server Settings" and then "Security Settings" and tried switching the drop-down box under "Connection security" to "None". (The option it had been set to was "SSL/TLS" and the only other option was "STARTTLS".) And then I restarted Thunderbird. I still got an error message. I also tried switching the "Authentication method" in the same section to "OAuth2". I also got an error message with that.

I also went to my Gmail account on Google and changed the password. Still errors. Then I removed two-step verification. Still errors.

Is there a bug with Thunderbird? This just started being an issue several days ago and nothing seems to fix it.

Yes, I have two Gmail accounts. I checked the SMTP server settings for them again and they both had the correct corresponding username. One of my Gmail accounts is working perfectly fine, thankfully, but the other one isn't. I could not find a "Passwords" option under "Tools/Options" (screenshot attached). I went to "Server Settings" and then "Security Settings" and tried switching the drop-down box under "Connection security" to "None". (The option it had been set to was "SSL/TLS" and the only other option was "STARTTLS".) And then I restarted Thunderbird. I still got an error message. I also tried switching the "Authentication method" in the same section to "OAuth2". I also got an error message with that. I also went to my Gmail account on Google and changed the password. Still errors. Then I removed two-step verification. Still errors. Is there a bug with Thunderbird? This just started being an issue several days ago and nothing seems to fix it.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

I turned the two-step verification back on for my Gmail account and generated an app password for this Gmail account. Then I entered it when Thunderbird asked me for my password. I received emails in that account, but still could got the original error message when trying to send an email: "Sending of the message failed. The message could not be sent because the connection to Outgoing server (SMTP) smtp.gmail.com was lost in the middle of the transaction. Try again."

I turned the two-step verification back on for my Gmail account and generated an app password for this Gmail account. Then I entered it when Thunderbird asked me for my password. I received emails in that account, but still could got the original error message when trying to send an email: "Sending of the message failed. The message could not be sent because the connection to Outgoing server (SMTP) smtp.gmail.com was lost in the middle of the transaction. Try again."
Fandt du dette nyttigt?
Citér
sfhowes
  • Top 10 Contributor
2012 løsninger 10078 svar

Valgt løsning

There is too much changing of settings. First, delete all entries in Tools/Options/Security/Passwords/Saved Passwords. Press Alt if the Menu Bar with Tools is hidden, or click the 3-bar icon, Options/Options/Security/Passwords/Saved Passwords.

Next, use these settings for IMAP accounts: imap.gmail.com on port 993, SSL/TLS, OAuth2 authentication, User Name = email address. For POP accounts: pop.gmail.com on port 995, SSL/TLS, OAuth2 authentication, User Name = email address. For SMTP: smtp.gmail.com on port 465, SSL/TLS, OAuth2 authentication, User Name = email address.

After you've deleted the passwords, restart TB and enter the regular account password, not an app password, in the OAuth browser window when prompted.

There is too much changing of settings. First, delete all entries in Tools/Options/Security/Passwords/Saved Passwords. Press Alt if the Menu Bar with Tools is hidden, or click the 3-bar icon, Options/Options/Security/Passwords/Saved Passwords. Next, use these settings for IMAP accounts: imap.gmail.com on port 993, SSL/TLS, OAuth2 authentication, User Name = email address. For POP accounts: pop.gmail.com on port 995, SSL/TLS, OAuth2 authentication, User Name = email address. For SMTP: smtp.gmail.com on port 465, SSL/TLS, OAuth2 authentication, User Name = email address. After you've deleted the passwords, restart TB and enter the regular account password, not an app password, in the OAuth browser window when prompted.
Fandt du dette nyttigt? 1
Citér

Spørgsmålsstiller

Thank you! These instructions finally helped me fix my account. I couldn't find the saved passwords until you mentioned there's an Alt menu.

Thank you! These instructions finally helped me fix my account. I couldn't find the saved passwords until you mentioned there's an Alt menu.
Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

I have tried all the password suggestions, changed the SMTP values and nothing worked. I have discussed this with Cox (internet provider) Toast.net the email provider and both said it was a Thunderbird problem. I have deleted Thunderbird and recreated an account with Toast.net with new generated profiles in Thunderbird with same error. It is a POP account with all settings per Toast.net. Here is the twist. I have a VPN service from Firetrust available and I started using it for all computer activity....no more errors when sending emails. Neither Cox or Toast.net could offer any reasons why that would solve problem, but kept saying it is a Thunderbird problem. HELP

I have tried all the password suggestions, changed the SMTP values and nothing worked. I have discussed this with Cox (internet provider) Toast.net the email provider and both said it was a Thunderbird problem. I have deleted Thunderbird and recreated an account with Toast.net with new generated profiles in Thunderbird with same error. It is a POP account with all settings per Toast.net. Here is the twist. I have a VPN service from Firetrust available and I started using it for all computer activity....no more errors when sending emails. Neither Cox or Toast.net could offer any reasons why that would solve problem, but kept saying it is a Thunderbird problem. HELP
Fandt du dette nyttigt?
Citér
sfhowes
  • Top 10 Contributor
2012 løsninger 10078 svar

Setup instructions for Toast are here. I recommend you turn off the VPN and see if TB works - VPNs are a common source of problems with email clients, even if they don't interfere with webmail operations.

Setup instructions for Toast are [https://support.toast.net/kb/a295/set-up-legacy-email-thunderbird.aspx?KBSearchID=41951 here]. I recommend you turn off the VPN and see if TB works - VPNs are a common source of problems with email clients, even if they don't interfere with webmail operations.
Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

I have spent a lot of time with Toast support individuals. Their current position is that they do not support TB and their SMTP server is working fine, therefore, the problem is with TB. The VPN is the only thing that lets me continue sending emails from my TB account. If I turn of VPN, no more sending via TB. Thanks for offering help.

I have spent a lot of time with Toast support individuals. Their current position is that they do not support TB and their SMTP server is working fine, therefore, the problem is with TB. The VPN is the only thing that lets me continue sending emails from my TB account. If I turn of VPN, no more sending via TB. Thanks for offering help.
Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

I guess I missed the logical question. Are there others using TB that have accounts on the Toast.net server? If so, any problems? My wife has an account on another Toast.net server(xxxxx.Toast.net) and her TB account works fine. My account on her computer does not work also when trying to send via the Toast.net server.

I guess I missed the logical question. Are there others using TB that have accounts on the Toast.net server? If so, any problems? My wife has an account on another Toast.net server(xxxxx.Toast.net) and her TB account works fine. My account on her computer does not work also when trying to send via the Toast.net server.
Fandt du dette nyttigt?
Citér
sfhowes
  • Top 10 Contributor
2012 løsninger 10078 svar

Post your server settings: Help/Troubleshooting, click Copy text to clipboard, paste into a reply, omitting everything below Extensions. If you can't send with the VPN off, then your settings have been changed from the ones recommended by Toast.

Post your server settings: Help/Troubleshooting, click Copy text to clipboard, paste into a reply, omitting everything below Extensions. If you can't send with the VPN off, then your settings have been changed from the ones recommended by Toast.
Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

Here is the information requested. I have worked with support team at Toast (Eric, Mike, Anthony). We have verified my server settings are the ones for mail.toast.net. My wife has TB on her laptop and my account on that computer can not send emails also. All emails work for her account (butter.toast.net) on either computer.


Name Thunderbird Version 68.6.0 Build ID 20200310192757 Update History Update Channel release User Agent Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.6.0 OS Windows_NT 10.0 Profile Folder (Local drive) Build Configuration about:buildconfig Memory Use about:memory Performance about:performance Registered Service Workers about:serviceworkers Launcher Process Enabled Multiprocess Windows 0/0 Disabled Remote Processes 0 Enterprise Policies Inactive Google Location Service Key Missing Google Safebrowsing Key Missing Mozilla Location Service Key Missing Safe Mode false Profiles about:profiles Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account1 (pop3) mail.toast.net:995 SSL/TLS Normal password mail.toast.net:587 STARTTLS Encrypted password true account2 (none) Local Folders None Normal password account5 (pop3) mail.butter.toast.net:110 None Normal password mail.butter.toast.net:587 None Any secure method (deprecated) true account10 (imap) imap.cox.net:993 SSL/TLS Normal password smtp.cox.net:465 SSL/TLS Normal password true Crash Reports for the Last 3 Days Report ID Submitted

All Crash Reports Remote Processes Type Count Extensions

Here is the information requested. I have worked with support team at Toast (Eric, Mike, Anthony). We have verified my server settings are the ones for mail.toast.net. My wife has TB on her laptop and my account on that computer can not send emails also. All emails work for her account (butter.toast.net) on either computer. Name Thunderbird Version 68.6.0 Build ID 20200310192757 Update History Update Channel release User Agent Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.6.0 OS Windows_NT 10.0 Profile Folder (Local drive) Build Configuration about:buildconfig Memory Use about:memory Performance about:performance Registered Service Workers about:serviceworkers Launcher Process Enabled Multiprocess Windows 0/0 Disabled Remote Processes 0 Enterprise Policies Inactive Google Location Service Key Missing Google Safebrowsing Key Missing Mozilla Location Service Key Missing Safe Mode false Profiles about:profiles Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account1 (pop3) mail.toast.net:995 SSL/TLS Normal password mail.toast.net:587 STARTTLS Encrypted password true account2 (none) Local Folders None Normal password account5 (pop3) mail.butter.toast.net:110 None Normal password mail.butter.toast.net:587 None Any secure method (deprecated) true account10 (imap) imap.cox.net:993 SSL/TLS Normal password smtp.cox.net:465 SSL/TLS Normal password true Crash Reports for the Last 3 Days Report ID Submitted All Crash Reports Remote Processes Type Count Extensions
Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

One other item. Something happened with the mail.toast.net server about two weeks ago. That is when I started not being able to send email. I have had the same email, TB, etc for almost 20 years. If the IT Support department at Toast maintains a Change Control Log for the servers, check to see if a patch was installed, server box was changed, a backup failed, or any errors appeared that were resolved or not resolved, etc.. My clients all were required to maintain Change Control Logs for just this type of problem. Thanks...

One other item. Something happened with the mail.toast.net server about two weeks ago. That is when I started not being able to send email. I have had the same email, TB, etc for almost 20 years. If the IT Support department at Toast maintains a Change Control Log for the servers, check to see if a patch was installed, server box was changed, a backup failed, or any errors appeared that were resolved or not resolved, etc.. My clients all were required to maintain Change Control Logs for just this type of problem. Thanks...
Fandt du dette nyttigt?
Citér
sfhowes
  • Top 10 Contributor
2012 løsninger 10078 svar

The Toast site provides settings for Legacy Email and Corporate Email, and both of them recommend port 465 and SSL/TLS security. The authentication is not stated, but assume it is 'normal password'. 'Encrypted password' authentication, as you have for account 1, is very rare. The outgoing server names for accounts 1 and 5 are different, but it's fair to assume the other settings should be the same.

The Toast site provides settings for [https://support.toast.net/kb/a295/set-up-legacy-email-thunderbird.aspx?KBSearchID=41951 Legacy Email] and [https://support.toast.net/kb/a290/set-up-corporate-mail-thunderbird.aspx Corporate Email], and both of them recommend port 465 and SSL/TLS security. The authentication is not stated, but assume it is 'normal password'. 'Encrypted password' authentication, as you have for account 1, is very rare. The outgoing server names for accounts 1 and 5 are different, but it's fair to assume the other settings should be the same.

Ændret af sfhowes den

Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

When this situation started, I contacted Toast. My settings for the outgoing server were - port 465, security was SSL/TLS, and password was Normal Password. Toast support told me that the supported configuration was - port 587, security was STARTTLS, and password was Encrypted Password. My original settings were working for years. Now neither settings work. The two accounts are different as they are on two different SMTP servers. My wife's account has less security and she has no problems with Toast. My last conversation with Toast support was it must be a TB problem. My hunch is Toast made a tweak or some change to the mail.toast.net server hardware or software which for some reason effects my account. In the past there was a problem happening at 9:00pm AZ time which blocked email on my wife's account for several days in a row. Support was adamant the problem was our computer network or connection. A few weeks later, support discovered that Tech Support was taking the server down for maintenance at midnight (9:00pm AZ time). Hence my hunch....

When this situation started, I contacted Toast. My settings for the outgoing server were - port 465, security was SSL/TLS, and password was Normal Password. Toast support told me that the supported configuration was - port 587, security was STARTTLS, and password was Encrypted Password. My original settings were working for years. Now neither settings work. The two accounts are different as they are on two different SMTP servers. My wife's account has less security and she has no problems with Toast. My last conversation with Toast support was it must be a TB problem. My hunch is Toast made a tweak or some change to the mail.toast.net server hardware or software which for some reason effects my account. In the past there was a problem happening at 9:00pm AZ time which blocked email on my wife's account for several days in a row. Support was adamant the problem was our computer network or connection. A few weeks later, support discovered that Tech Support was taking the server down for maintenance at midnight (9:00pm AZ time). Hence my hunch....
Fandt du dette nyttigt?
Citér
wsu 0 løsninger 7 svar

P.S. The link you provided for Legacy Email was for a IMAP and my account and my wife's are POP accounts. Toast would prefer POP accounts go away and there be only IMAP.

P.S. The link you provided for Legacy Email was for a IMAP and my account and my wife's are POP accounts. Toast would prefer POP accounts go away and there be only IMAP.
Fandt du dette nyttigt?
Citér
sfhowes
  • Top 10 Contributor
2012 løsninger 10078 svar

The links stated the IMAP settings, but my previous reply concerned SMTP which is the same for POP or IMAP. If in fact they still support POP, which isn't apparent from their site, the incoming server is probably the same as the IMAP server, but on port 995, and the authentication and security settings should be the same. They don't document any requirement for Encrypted password authentication, and it's not surprising they claim the problem is with TB - the typical response from poorly managed mail services.

The links stated the IMAP settings, but my previous reply concerned SMTP which is the same for POP or IMAP. If in fact they still support POP, which isn't apparent from their site, the incoming server is probably the same as the IMAP server, but on port 995, and the authentication and security settings should be the same. They don't document any requirement for Encrypted password authentication, and it's not surprising they claim the problem is with TB - the typical response from poorly managed mail services.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.