X
Tryk her for at gå til webstedets mobilversion.

Supportforum

If I start Firefox by clicking a link in another application or operating system a window without Menu Bar items is opened

Skrevet

As stated in the title, everytime when I open a link in the operating system (i.e. clicking on a link in an email or opening a website with Alfred) while Firefox is not already running, the following happens:

1. Two Firefox windows are opened 2. One window opens the requested website (https://startpage.com in the Screenshots) but has no context items in the Menu Bar above. 3. The second opens at Home and has the items in the Menu Bar.

I am using Mac OS Catalina (multiple versions) and the issue persisted a complete reinstall (I wiped my hard drive and did a clean install) of the operating system. I tried mainstream Firefox 73.0 and Firefox Dev Edition latest beta 74.0b2. (Used `brew cask` to install) Also I do have another Mac on High Sierra that does not have this issue.

As stated in the title, everytime when I open a link in the operating system (i.e. clicking on a link in an email or opening a website with Alfred) while Firefox is not already running, the following happens: 1. Two Firefox windows are opened 2. One window opens the requested website (https://startpage.com in the Screenshots) but has no context items in the Menu Bar above. 3. The second opens at Home and has the items in the Menu Bar. I am using Mac OS Catalina (multiple versions) and the issue persisted a complete reinstall (I wiped my hard drive and did a clean install) of the operating system. I tried mainstream Firefox 73.0 and Firefox Dev Edition latest beta 74.0b2. (Used `brew cask` to install) Also I do have another Mac on High Sierra that does not have this issue.
Vedhæftede skærmbilleder

Valgt løsning

This is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Læs dette svar i sammenhæng 1
Citér

Yderligere systemdetaljer

Installerede plugins

None

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:74.0) Gecko/20100101 Firefox/74.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4334 løsninger 60928 svar

Start Firefox in Safe Mode first {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Then try using a link. Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode first] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Then try using a link. Is the problem still there?
Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
17757 løsninger 160590 svar

Valgt løsning

This is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

This is a known bug on Catalina. *[https://bugzilla.mozilla.org/show_bug.cgi?id=1603956 Bug 1603956] - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Fandt du dette nyttigt? 1
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.