X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Tried to install FF on Debian 10, can't update to the last version

  • Ingen svar
  • 1 har dette problem
  • 3 visninger
Skrevet

So I wanted to install latest version of FF on Debian 10, since it only comes with ESR version. I tried downloading the .tar files and creating a desktop shortcut, but it won't work, and I didn't know how to update it and since they release version 73 while I was trying with the previous version it started to collide and it didn't felt the good way (I'm a noob; pretty obvious). So I saw this reddit post(https://www.reddit.com/r/debian/comments/86i20e/how_to_install_the_latest_firefox/), which seemed good to me, I installed Debian unstable and now FF is on my desktop and such, but I can't update it to the last version. So I won't let me use my other profile (which was on version 73) and I have to use a regular one which I dislike a lot. How can I use latest FF version and update it as soon as a new version is released?

I'm using Gnome btw, here are the command lines from the reddit post:

edit the /etc/apt/sources.list file add deb http://ftp.us.debian.org/debian/ unstable main contrib non-free sudo nano /etc/apt/preferences then paste this

Package: * Pin: release a=stable Pin-Priority: 900

Package: * Pin: release a=unstable Pin-Priority: 10 sudo apt update sudo apt remove --purge firefox-esr sudo apt install -t unstable firefox

So I wanted to install latest version of FF on Debian 10, since it only comes with ESR version. I tried downloading the .tar files and creating a desktop shortcut, but it won't work, and I didn't know how to update it and since they release version 73 while I was trying with the previous version it started to collide and it didn't felt the good way (I'm a noob; pretty obvious). So I saw this reddit post(https://www.reddit.com/r/debian/comments/86i20e/how_to_install_the_latest_firefox/), which seemed good to me, I installed Debian unstable and now FF is on my desktop and such, but I can't update it to the last version. So I won't let me use my other profile (which was on version 73) and I have to use a regular one which I dislike a lot. How can I use latest FF version and update it as soon as a new version is released? I'm using Gnome btw, here are the command lines from the reddit post: edit the /etc/apt/sources.list file add deb http://ftp.us.debian.org/debian/ unstable main contrib non-free sudo nano /etc/apt/preferences then paste this Package: * Pin: release a=stable Pin-Priority: 900 Package: * Pin: release a=unstable Pin-Priority: 10 sudo apt update sudo apt remove --purge firefox-esr sudo apt install -t unstable firefox
Citér

Yderligere systemdetaljer

Installerede plugins

uMatrix; uBlock Origin; HTTPS Everywhere; Decentraleyes; Privacy Badger; Cookie AutoDelete and also I'm using Ghacks.js

Program

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Yderligere information

Luk

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.