Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default Search Engine Reverts Back to Google

  • 4 svar
  • 1 har dette problem
  • 104 visninger
  • Seneste svar af FredMcD

more options

In the Search panel of the Preferences page I have changed my preferred search engine to DuckDuckGo. It will stay as this until I quit and reopen Firefox, when it reverts back to Google. I've tried this a few times but it always goes back. I've looked for a cookie that might be being deleted, but there are none on my machine (that I can see).

I'm running Firefox 72.0.2 on a Mac with Catalina 10.15.2 and also have Firefox apps on an iPhone and iPad.

Can anyone shed any light? Thanks in advance

In the Search panel of the Preferences page I have changed my preferred search engine to DuckDuckGo. It will stay as this until I quit and reopen Firefox, when it reverts back to Google. I've tried this a few times but it always goes back. I've looked for a cookie that might be being deleted, but there are none on my machine (that I can see). I'm running Firefox 72.0.2 on a Mac with Catalina 10.15.2 and also have Firefox apps on an iPhone and iPad. Can anyone shed any light? Thanks in advance

Valgt løsning

Thanks for the help.

I found the culprit to be an app called Cookie (from SweetP Productions) which had a setting named "Other Search Engines". I turned this off and problem solved.

Læs dette svar i sammenhæng 👍 0

Alle svar (4)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Google “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

more options

Also see; https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Valgt løsning

Thanks for the help.

I found the culprit to be an app called Cookie (from SweetP Productions) which had a setting named "Other Search Engines". I turned this off and problem solved.

more options

Glad to help. Safe Surfing.