X
Tryk her for at gå til webstedets mobilversion.

Supportforum

I have moved my files from Windows 7 computer to Windows 10 computer but only able to view pdf with Edge app how can I open with firefox viewer

Skrevet

I recently migrated Firefox profiles and general files from Windows 7 computer to a new Windows 10 computer. However my Pdf files created on my old computer open up via the Edge app. on the new one. I want to use the Firefox viewer but am not even able to make the Firefox app. the default. Any suggestions anyone?

I recently migrated Firefox profiles and general files from Windows 7 computer to a new Windows 10 computer. However my Pdf files created on my old computer open up via the Edge app. on the new one. I want to use the Firefox viewer but am not even able to make the Firefox app. the default. Any suggestions anyone?
Vedhæftede skærmbilleder

Valgt løsning

Wow! I'm glad to hear that you figured it out. That's great!


Browse Safe!

Læs dette svar i sammenhæng 0
Citér

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Yderligere information

Luk
RobertJ
  • Top 10 Contributor
140 løsninger 1449 svar

Hi RIDOCK, In your screenshot, if you want pdf attachments to open in Firefox, set Firefox as your default browser in Windows settings.

As far as pdf files on your PC: go to any pdf file, right click on it, select Open With and Choose Another App. In the selection window that opens select Firefox and tick the checkbox next to Always Use This App To Open PDF Files.

Hi RIDOCK, In your screenshot, if you want pdf attachments to open in Firefox, set Firefox as your default browser in Windows settings. As far as pdf files on your PC: go to any pdf file, right click on it, select Open With and Choose Another App. In the selection window that opens select Firefox and tick the checkbox next to Always Use This App To Open PDF Files.
Fandt du dette nyttigt? 0
Citér
RobertJ
  • Top 10 Contributor
140 løsninger 1449 svar

Amendment: In your mail app (it looks like you're using Thunderbird) you also need to set an Open With. Just like in Firefox in the Applications section.

Amendment: In your mail app (it looks like you're using Thunderbird) you also need to set an Open With. Just like in Firefox in the Applications section.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Hi My Cheese etc, Your remedy does not work.I have tried this way already, but Firefox does not come up as an option when I click on 'Choose Another App' I was able to set Thunderbird as default mail program (I also have an outlook email address) . I have a feeling Microsoft is pushing me towards their app Edge. When I first used Edge to download and install Firefox just after setting this machine up I was reminded that Edge is designed for Windows 10 (or words to that effect) Perhaps Microsoft has caught that Apple disease of pushing their own products Thanks for your quick response though, Ridock

 PS I did not send a screenshot ,I don't know where that one came from !! -True !
Hi My Cheese etc, Your remedy does not work.I have tried this way already, but Firefox does not come up as an option when I click on 'Choose Another App' I was able to set Thunderbird as default mail program (I also have an outlook email address) . I have a feeling Microsoft is pushing me towards their app Edge. When I first used Edge to download and install Firefox just after setting this machine up I was reminded that Edge is designed for Windows 10 (or words to that effect) Perhaps Microsoft has caught that Apple disease of pushing their own products Thanks for your quick response though, Ridock PS I did not send a screenshot ,I don't know where that one came from !! -True !
Fandt du dette nyttigt?
Citér
RobertJ
  • Top 10 Contributor
140 løsninger 1449 svar

In the How do you want to open this file? window - keep drilling. Scroll down and click on More Apps... If it isn't in that list, select Look for another app on this PC... In the Open With... window, double-click Mozilla Firefox select Firefox and Open.

In the How do you want to open this file? window - keep drilling. Scroll down and click on More Apps... If it isn't in that list, select Look for another app on this PC... In the Open With... window, double-click Mozilla Firefox select Firefox and Open.
Fandt du dette nyttigt? 0
Citér

Spørgsmålsstiller

Hi My Cheese etc, as I explained above , I have done all this and at no stage does the Firefox app appear. Strange isn't it . Ridock.

Hi My Cheese etc, as I explained above , I have done all this and at no stage does the Firefox app appear. Strange isn't it . Ridock.
Fandt du dette nyttigt?
Citér
RobertJ
  • Top 10 Contributor
140 løsninger 1449 svar

Try this. Go to - Windows Settings -> Apps -> Default Apps (on the left) listed under the Reset button, you will see Choose Default Apps By File Type scroll down until you see PDF click on the line to the right of that and see if Firefox is there.

If this doesn't solve the issue then, I would suspect a Registry error problem.

Try this. Go to - Windows Settings -> Apps -> Default Apps (on the left) listed under the Reset button, you will see Choose Default Apps By File Type scroll down until you see PDF click on the line to the right of that and see if Firefox is there. If this doesn't solve the issue then, I would suspect a Registry error problem.
Fandt du dette nyttigt? 0
Citér

Spørgsmålsstiller

Hi Cheese etc, Choosing default apps by file type gives me two options , Edge or choosing something from the Microsoft Store. Mucking around in the Registry is above my pay grade I feel. Tnks for your concern, Ridock

Hi Cheese etc, Choosing default apps by file type gives me two options , Edge or choosing something from the Microsoft Store. Mucking around in the Registry is above my pay grade I feel. Tnks for your concern, Ridock
Fandt du dette nyttigt?
Citér
RobertJ
  • Top 10 Contributor
140 løsninger 1449 svar

I wouldn't recommend fooling around in the Registry, anyway. Sometimes, changing defaults back and forth can "free up" the Registry. Switch your default browser to Edge, wait a few seconds, then change it back to Firefox. Similarly, change the default app for pdf's to Adobe, then back. Anything is better than possibly making your Registry worse.

I wouldn't recommend fooling around in the Registry, anyway. Sometimes, changing defaults back and forth can "free up" the Registry. Switch your default browser to Edge, wait a few seconds, then change it back to Firefox. Similarly, change the default app for pdf's to Adobe, then back. Anything is better than possibly making your Registry worse.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Hi Cheese etc, I managed to solve the issue but not quite sure how I did it. In Open with ..... window I followed my nose and somehow found myself in a window listing my programs - I opened Mozilla Firefox program and the file opened up ok.Repeated that procedure with another file. It too opened up. Then I went to Choosing Default by File Type and lo and behold Firefox now appeared as an option which I of course applied as my default. All my PDF files in downloads etc now have the Firefox icon displayed beside them. I hope nothing else on my computer hasn't been disturbed but here's hoping mission accomplished. Tnks for your concern Ridock

Hi Cheese etc, I managed to solve the issue but not quite sure how I did it. In ''Open with ..... window I followed my nose and somehow found myself in a window listing my programs - I opened Mozilla Firefox program and the file opened up ok.Repeated that procedure with another file. It too opened up. Then I went to Choosing Default by File Type and lo and behold Firefox now appeared as an option which I of course applied as my default. All my PDF files in downloads etc now have the Firefox icon displayed beside them. I hope nothing else on my computer hasn't been disturbed but here's hoping mission accomplished. Tnks for your concern Ridock
Fandt du dette nyttigt?
Citér
RobertJ
  • Top 10 Contributor
140 løsninger 1449 svar

Valgt løsning

Wow! I'm glad to hear that you figured it out. That's great!


Browse Safe!

Wow! I'm glad to hear that you figured it out. That's great! Browse Safe!
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.